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1 Ruskin software
Ruskin is the only tool you need to manage all your RBR instruments and measurement data. It is available for Mac® and 
Windows® PC. 

Use the Ruskin software to do the following:

 Configure, schedule, and enable multiple instruments

 Estimate your deployment times

 Download your data after logging

 View your datasets graphically

 Export your data in various formats

 Analyse your data

 Change the calibration coefficients for your instrument

 Perform user calibration

 Contact RBR

RSK files generated by Ruskin contain raw measurement data, firmware and software versions, dates and times, 
sampling settings, power settings, measured and derived parameters, errors and events, other diagnostic information. 
They can be read directly in Matlab, or exported to Excel, OceanDataView®, or text files. 

Find Ruskin software for Mac and PC on the USB stick included with your instrument, or visit the RBR website to 
download the latest version. 

The most recent software updates, release notes, Ruskin user guides, instrument guides, and quick start guides are 
available from the Help menu in Ruskin.

https://rbr-global.com/products/software/
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2 Ruskin interface
Ruskin software has a user-friendly interface which consists of a Toolbar and three main windows: Navigator, 
Properties, and Plot.

In the Navigator window, you will find the list of instruments connected to Ruskin, as well as MLM and winches (if 
applicable), and dataset files. 

When an instrument on the list is selected, the Properties window displays three tabs with information related to this 
instrument: Deployment, Datasets, and Calibration. Use these tabs to configure your deployment, check the calibration 
certificates, and verify your parameters.

The data plot will appear in the Plot window below if the realtime option is available and selected for this instrument, 
or if you click the Poll button  on the far right of the toolbar. 

Click-and-drag window tabs to rearrange the windows within Ruskin, or move a window outside of Ruskin. Hover over a 
side of a window, and when the cursor becomes a two-way arrow , move it to adjust the window size. 

Click the Close  button in the top right corner to close a window. For example, you can close the Navigator window 

to have a better view of the Properties. The closed window icon will appear on the sidebar (in this case, Navigator 

). Click the Multiple windows  button above the closed window icon to re-open it. 

https://docs-rbr.atlassian.net/wiki/spaces/RUSKINGEN4/pages/692879362/Datasets
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Double-click a window tab to maximise that window, and double-click the tab again to return it to the original size. 

Alternatively, use the Single window  and Multiple windows  buttons. 

The Toolbar at the top left above the Navigator window has four dropdown menus. If you are using a Mac computer, it 
appears as follows:

On a Windows PC, the Toolbar looks slightly differently:

The rest of the interface is the same between the two systems. 

2.1 File
Go to the File dropdown menu to open or close a dataset, export your data, and see the list of available datasets. The 
Datasets menu in the Navigator windows duplicates some of these options for convenience.

When you restart Ruskin, it returns to its original layout. 
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2.2 Instruments
Go to the Instruments dropdown menu to Simulate an instrument, Update firmware, set up Automatic tasks, or access 
the Utilities.

You can also access the Simulate… and Automatic tasks options by selecting the Instruments context menu in the 
Navigator window.

2.3 Help

Go to the Help dropdown menu to access the latest 
Release notes and Documentation, Comment on 
Ruskin..., Check for updates…, as well as access Feature 
codes. On Mac, you can also use the Search option. 

2.4 Ruskin / Options

On your Mac, go to the Ruskin dropdown menu to access 
information on your current software version, edit your 
Settings, or Quit Ruskin. Note that the rest of the options 
on this dropdown menu depend on your operating 
system and are external to Ruskin. 

On your Windows PC, edit you Settings using Options > 
Preferences. 

Automatic tasks and Utilities are not applicable for sensors.   

The Utilities option is a support tool. Contact RBR before using it. 

mailto:support@rbr-global.com
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3 Installation
Ruskin is the only piece of software you need to operate your RBR instruments. RBR releases Ruskin software versions 
compatible with Mac and PC (Ruskin Desktop), as well as with iOS® and Android™ (Ruskin Mobile). 

Install the Ruskin Mobile app on your mobile device by going to the Apple App store or Google Play. 

Follow the steps below to install Ruskin Desktop on your computer. 

3.1 Install Ruskin on PC
You can install Ruskin on a PC that runs the Windows 7, 8, 10, or 11 operating system.

The minimum requirements for Ruskin are:

 OS = Windows 7

 Processor speed = 1.4GHz

 RAM required = 8GB

 Display resolution = 1024x768

 1920x1080 (recommended)

 HDD space for installation = 2GB

The instruments use either a USB interface or an RS-232 serial port to communication with Ruskin.

Steps

1. Connect the USB stick included with your instrument to a port on your computer.

2. Navigate to the Ruskin Installation folder and double click on the on the file RuskinSetup.exe .

3. Follow the installation wizard. By default, Ruskin will be installed to C: \RBR

4. At the end of the installation, you will see a prompt asking, “Would you like to install the logger driver at this 
time?”

5. Click Yes to install the drivers

A shortcut to Ruskin will appear on the desktop and in a Start menu folder.

3.2 Install Ruskin on Mac
You can install Ruskin on a Mac running OS X 10.12 (Sierra) or later.

Realtime sensors will not require USB drivers to operate, they are only required for our standard and compact 
instruments.

You may need to run the setup application as an administrator to install the driver correctly.

The most recent version of Ruskin software can be found at https://rbr-global.com/products/software.

Always use the default Applications folder as the working directory.

https://rbr-global.com/products/software
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Steps

1. Connect the USB stick included with your instrument to a port on your adaptor.

2. Navigate to the "OSX" folder and double-click on the file Ruskin.dmg .

3. When the disk image window opens, drag the Ruskin icon into the Applications directory and wait for the copy 
to complete. An application named "Ruskin" will appear in the Applications folder.

4. Right-click on the icon, and select Open.

5. The dialogue box shown below will prompt you to authorise the opening of Ruskin. 

3.3 Update Ruskin
To take advantage of new features and bug fixes, ensure that you are using the most recent version of Ruskin. 

 Find the most recent version of Ruskin at https://rbr-global.com/products/software.

 Receive an automatic notification about a new release when you start the application.

 Check from within Ruskin by navigating to Help > Check for updates…. 

 Send an email to support@rbr-global.com, subject: "Ruskin update request", and ask us to add you to the 
mailing list. You will receive an email as soon as the new version is released. 

If you have a broadband connection, simply follow the installation instructions on your computer. Otherwise, request a 
USB stick from RBR.  

.

You may need to navigate to System Settings… > Privacy & Security > Allow applications from and select 
App Store & Known Developers to complete the installation.

It is not necessary to uninstall the older version of Ruskin before installing the newer version. The installation 
program deletes the older files before installing the newer ones. It does not delete any Ruskin data files or log 
files.

https://rbr-global.com/products/software
mailto:support@rbr-global.com?subject=Ruskin%20update%20request
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3.4 Uninstall Ruskin
Uninstall Ruskin only if you no longer need to manage RBR instruments from your computer.

It is not necessary to uninstall the older version of Ruskin before installing the newer version. The installation program 
deletes the older files before installing the newer ones. For more information, see Update Ruskin.

Uninstall Ruskin on a PC, Windows 7, 8, 8.1, 10, or 11

1. Go to Start > Control Panel > Programs.

2. Under Programs and Features, click Uninstall a program.

3. Find Ruskin on the list.

4. Click Ruskin to highlight it.

5. Click Uninstall.

Uninstall Ruskin on a Mac, OS X 10.12 or later

Move the Ruskin application from Applications to the Trash.

Removing Ruskin will not delete your data files or your diagnostic logs, provided they have not been saved to 
the Ruskin installation folder.
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4 Support

You can get in touch with RBR in several different ways:

 Send us an email.  For technical questions, use support@rbr-global.com, and for general inquiries, info@rbr-
global.com.

 Contact us via the website at https://rbr-global.com/contact-us/.

 Call us at +1 (613) 599-8900.

 Send us a bug report from within Ruskin itself Help > Comment on Ruskin

The Help menu in Ruskin offers access to technical documentation, feedback forms, and software updates.  On Mac, 
you can also search for Ruskin menu options. 

4.1 Release notes
Go to Help > Release notes to open the Welcome window. It will outline new features, improvements, and bug fixes 
associated with each release version.

Select Click here to see all Release notes to see the full history of the release notes. The link will take you to the RBR 
support page. Alternatively, scroll down to see brief recaps of the release notes from all previous versions. 

To exit and return to the Navigator mode select x on the Release notes tab

4.2 Documentation
Select Help > Documentation to access an instruments Quick Start Guide, Instrument Guide, and Command reference.

Documentation can also be found on the RBR website.  

When experiencing an issue, look for a solution under the Help menu before contacting RBR. 

mailto:support@rbr-global.com
mailto:info@rbr-global.com
https://rbr-global.com/contact-us/
https://docs.rbr-global.com/support/ruskin/release-notes
https://rbr-global.com/support/documentation/
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4.3 Comment on Ruskin
Sending a bug report from within Ruskin allows you to include the diagnostic logs, RSK datasets, screenshots, and any 
other files that could help us reproduce the problem and find the solution as quickly as possible.

To submit a bug report:

1. Click on Help > Comment on Ruskin... . The Feedback to RBR form will appear.

2. Enter your Name and Email address. 

3. Enter a brief Summary of the problem. 

4. Provide a detailed Description (serial number for the instrument, overview of the problem, deployment details, 
initial tests, and, for software bugs, steps to reproduce the issue)

5. Include any attachments, if required. 

6. Verify all the information entered and select Submit.

4.4 Check for updates
To search for the latest software version, go to Help > Check for updates.

.If your software is up-to-date, no further action will be required. 

If an update is found, Ruskin will offer to install it. Follow the prompts then restart Ruskin for the updates to take effect.

4.5 Feature codes
Sometimes, RBR may release new features to certain users only, as a beta trial. This includes:

 Features in early development  

 Features supporting a new product, in preparation for the product launch

 Features requested by a specific customer

Usually, the goal is to get feedback and improve the feature before its official release. Contact your sales representative 
or RBR support team at support@rbr-global.com if you have questions about your feature code.

To access a new feature:

1. Click on Help > Feature codes..., to access the Feature codes window.

2. Enter the feature code provided by RBR.

3. Click ADD.

If the code is correct, Ruskin will save the feature in the local database and enable it. In most cases, you will have access 
to the new feature immediately, without restarting Ruskin. If addition instructions are required, you will receive them 
along with the feature code.

Errors

 The feature code is not valid.

 This error may indicate the code was entered incorrectly or it is not compatible with the current version 
of Ruskin.

 The feature code is already enabled.

 This error may occur when another user has already activated this code. 

mailto:support@rbr-global.com
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5 Quick start - Ruskin Desktop
Ruskin Desktop version is designed for computers and laptops. It generates dataset files which include raw 
measurement data, firmware and software versions, dates and times, sampling settings, power settings, measured and 
derived parameters, errors and events, calibration coefficients, and diagnostic information, offering the fullest Ruskin 
experience. 

5.1 Simulate an instrument
Ruskin can simulate most instruments and sensors that RBR produces. We recommend that you experiment with 
different simulated options before enabling a schedule for your actual deployment. This practice will also help you 
become more familiar with how an RBR instrument interacts with Ruskin and how to configure its settings and 
features. Work with simulated instruments the same way as you work with a real RBR instrument, configuring, 
calibrating, and fetching data.

Steps

1. From the Instruments menu, click Simulate…

The Configure simulated instrument dialog box 
will appear.

2. Click your instrument family and make your 
selections.

3. Click OK to proceed.

4. Your instrument will appear under Instruments in 
the Navigator windown. Simulated instruments 
will have the prefix “sim” in front of their name.

Currently, you cannot enable simulated instruments or download their data. For more information, see Deploy 
your instrument.

Depending on the instrument selected, the Options dropdown menu may contain | fast sampling rates, | tide 
and | wave variants, tilt, or no options at all (in that case, the menu will be greyed out). 
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The instrument properties will be displayed on the right, under three tabs:

 Deployment - displays status, clock, sampling mode and speed, power options, and deployment estimates 
based on these parameters.

 Datasets - displays the datasets contained in the instrument. Provides functionality to download and delete 
individual datasets.

 Calibration - allows access to the current calibrations for each channel in the instrument.

Familiarise yourself with the instrument by changing configuration options and comparing deployment estimates. 
Select the desired configuration using the dropdown options or entering the values manually in the fields provided. 

For simulated instruments, the Plot window will remain empty unless you click the Poll button . 

Manage multiple instruments by switching between them in the Navigator window. 

5.2 Deploy your instrument
Before using your RBR instruments, you may want to experiment with different options by simulating your instrument
on Ruskin.

When you are ready to use your physical RBR instrument, follow the steps below to ensure that you measure exactly 
what you want on the first attempt. 

Steps

 Locate a USB-C port inside of the instrument. See the section on opening and closing your instrument in the 
relevant Instrument Guide for more details. Guides are available on Ruskin under Help > Documentation. 

 Plug one end of the USB cable (USB-C to USB-C, provided with your instrument) into this port and the other, in 
the USB port on your computer.
The instrument will appear in the Navigator view after a few seconds. The properties for the instrument will be 
displayed in the Properties window, grouped under three tabs: Deployment, Datasets, and Calibration.

 If you are using the instrument for the first time, you can use either the default preferences or specify your own. 
For more information, see Settings > General. You can change them at any time.

 Click the instrument you want to use. Verify that it contains the expected sensors under the Calibration tab. 

 Click the Calibration tab to view or modify calibration coefficients.

 Click the Deployment tab and go to the Scheduling cards section to select the mode and speed of 
measurements.  

 Click the Enable button at the bottom of the Deployment tab to take samples according to the schedule that 
you specified.

To remove a simulated instrument from Ruskin, right-click the instrument name in the Navigator window, and 
select Disconnect. You can also use the Instruments menu.
 Alternatively, simply close its Plot tab by clicking the X. The instrument will disappear from the list.

Ruskin will allow a deployment to run until the instrument can no longer sample. This could be due to a full 
memory or due to power supplies being exhausted.  It will display the estimated battery usage and storage 
capacity based on the parameters you enter. The green widget next to End will indicate the number of days 
your instrument would be sampling, along with the icon representing the limiting factor, battery or memory.
Carefully consider this information before you enable a deployment schedule. For more information, see 
Schedule.

https://docs-rbr.atlassian.net/wiki/spaces/RUSKINGEN4/pages/692879362/Datasets
https://docs-rbr.atlassian.net/wiki/spaces/RUSKIN/pages/17432841/General
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Your deployment will continue until the battery runs out, the memory is full, or you stop your schedule 
manually. 

 When your deployment stops, click the Download latest button at the bottom of the Deployment tab to 
transfer all the sampled data from the instrument to your computer. For more information, see Download latest.
As soon as you download a new dataset, it will appear in the Navigator window. Refer to Dataset files for details 
on managing and analysing your data.

5.3 Recover your instrument and download data
When deployment is complete, recover your instrument and follow these steps to download your data.

Steps

1. Start Ruskin.

2. Carefully remove the battery end-cap. See "Opening and closing the instrument" section in the corresponding 
RBR Instrument Guides for more details. The Guides are available on Ruskin under Help > Documentation. 

3. Locate a USB-C port inside of the instrument.

4. Plug one end of the USB cable (USB-C to USB-C, provided with your instrument) into this port and the other, in 
the USB port on your computer.

5. The instrument will appear in the Navigator view after a few seconds.

6. Under the Datasets tab, click Download. See Download latest for details.

7. The file is automatically downloaded to the location specified in Settings > General. See General on steps to set 
up your default location. 

8. Evaluate your data. See Analysis for details.

Disconnect from your instrument

To disconnect an instrument from Ruskin, right-click it in the Navigator window, and select Disconnect. You can also 
use the Instruments menu.

 Alternatively, simply close its Plot tab by clicking the X. The instrument will disappear from the list. Please note that 
you will be able to reconnect to it at any time because Ruskin remembers the port of a plugged instrument.

Reconnect to your instrument

To restore a closed connection to an instrument on Ruskin, click Instruments in the Navigator window. A list of all 
instruments physically connected to your computer will appear in the Properties window, under the Connections tab.

Find your instrument and deselect its checkbox, then reselect it again. Your instrument will re-appear in the Navigator
window.

To restore a closed connection to an instrument on Ruskin, click Instruments in the Navigator window. A list 
of all instruments physically connected to your computer will appear in the Properties window.
Find your instrument and deselect its checkbox, and then select it again.
Your instrument will re-appear in the Navigator window.

Flooded instruments may be under pressure and opening them may be dangerous. Take precautions when 
opening an instrument after deployment.
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Remove your instrument

To completely remove your instrument from Ruskin, unplug it from your computer. 

Alternatively, deselect the checkbox next to your instrument, and Ruskin will disable transport to its port. 

If you uncheck this port, Ruskin will never detect the instrument again on that port. To use this port for an 
instrument, the port must be checked/enabled.
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6 Connections
Use the Connections tab to view and manage devices connected to your computer via physical ports or Ethernet.

In the Navigator window, click Instruments. The Connections tab will open on the right. The table will include ports, 
statuses, RF latency selections, and the device type for each connected device.

Column Information

Port If your instrument is plugged in to your computer, this column will identify the physical port by 
name, such as "COM5" (if using Windows) or by its address, such as "/dev/
tty.usbmodem141101"  (if using MAC OS). 

Status The column will display a success message, such as "Connected to RBRconcerto³ 209681", or 
an error message, such as "Unable to connect to host".

RF latency (s) From the dropdown menu, select a value up to 29 seconds.  The selected value will extend the 
allowable time for an instrument to respond to a command. Use this option when on a long 
cable or slow Wi-Fi connections.

Device The column will display the device type for each connected device:

 Logger: Instruments connected via USB, serial (RS-232), or TCP connections

 RS-485: Instruments connected via serial (RS-485) connections

 GPS: NMEA streaming devices

See Deploy your instrument on how to locate the USB-C port on your instrument and connect it to your computer. 

As soon as you plug in an instrument, Ruskin will detect it and add it to the list.

https://docs-rbr.atlassian.net/wiki/spaces/RUSKIN/pages/17432673/Deploy+your+instrument+1
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Click on one of the instruments to switch to its Deployment tab.  

If you unplug an instrument, the port will remain enabled as long as the port checkbox remains selected. Ruskin will 
automatically reconnect to the instrument when it is plugged back in. 

Deselect the checkbox next to your instrument to disable transport to its port.  After this, Ruskin will not detect any 
instrument plugged into this port.

To restore transport, reselect the checkbox. Your instrument will re-appear in the Navigator window.
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7 Deployment
Use the Deployment tab to set up your deployment parameters. 

After setting up a desired schedule, click Enable.  New values will replace all previously stored deployment and 
schedule parameters.

You can also use the Deployment tab to view general information for each of your instruments, such as serial number, 
firmware version, power type (internal or external), and voltage. 

The SoC (State of Charge) value indicated for the internal source indicates the power remaining in your batteries. 

7.1 Update firmware
Ruskin automatically checks if your instrument firmware is up-to-date. Updates may be critical, routine, or customised. 

If a newer version is available and this update is critical, the Update firmware button and a warning message will 
appear at the top of the Deployment tab. 

See Critical firmware updates for details. 

The instrument must be disabled to change a setting. A new deployment must be enabled for the new settings 
to take effect.

It is not a good idea to use voltage as a health indicator of the battery as the voltage drop in certain 
chemistries can be very sharp.
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7.2 Schedule

The Schedule section includes four fields: Status, Clock, 
Start, and End. 

The Status field displays the current state of your 
instrument.

Status Description

Not enabled A deployment has not been enabled.

Configuring instrument Ruskin is writing the deployment configuration to the instrument.

Schedule enabled A deployment has been enabled, but the start time has not yet been reached.

Paused A deployment has been enabled, but a gating condition has not been met.

Logging in progress A deployment has been enabled and the instrument is currently obtaining 
samples and recording them to memory.

Logging, memory full A deployment has been enabled and the instrument is currently obtaining 
samples, but they are not being recorded to memory as there is no available 
space. Data continues to be transmitted over the chosen realtime link.

Stopped, schedule complete A deployment has reached the end time and so has been stopped.

Stopped, memory full The memory has been completely filled with samples and so logging has been 
stopped.

Stopped, user request An enabled deployment has been stoped by user intervention.

Failed An internal error has occurred during a deployment.

Battery failed An internal error with regarding the batteries has occurred.
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Clock

The instrument clock may drift up to 60s per year. Hover 
your mouse over the time value to display the offset.

Synchronise the instrument clock before each deployment. Select UTC or Local  time, depending on your preferences. 

Start

Specify the Start date using the dropdown calendar, and the Start time using the up and down arrows. Alternatively, 
select Now to start logging as soon as the Enable button is clicked. 

End

The End date is calculated by Ruskin autonomy engine and indicates when your deployment is likely to stop. This is 
based on sampling schedule, mode, and power selections . Ruskin autonomy engine provides feedback on which 
parameter (power or memory) will be exhausted first. 

The parameter in the green bar is the true deployment estimate. In the example shown, your deployment will last 155 
days, until the battery is exhausted. 

The parameter in the orange bar indicates that your instrument could last longer than the number of days indicated in 
the green if the preceding parameter were not a factor.

Ruskin autonomy engine

Ruskin autonomy engine relies on several parameters to estimate the deployment end date: sampling rate, power 
options, and memory. One of the key factors is battery life.  

To manually edit the originally set date and time values, uncheck Now.

Ruskin uses power tracking data stored in the instrument to adjust its autonomy calculation to account for 
power already used from previous deployments. If new batteries are inserted in the instrument, check the 
‘fresh’ check box next to the battery selection. This will indicate that the autonomy calculation should assume 
fresh batteries for the deployment.

If the End logging date is power dependent and if you know that the instrument will be operating under very 
cold conditions, you may want to lower the demands on the battery by lengthening your sampling period or 
opting for different battery chemistry.
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Battery life prediction is a complicated issue. In RBR instruments, it is a strong function of the type of instrument, type 
and number of sensors attached, sampling mode (sampling rate, gating conditions, realtime data collection), and water 
temperature during the deployment. Manufacturer data for the batteries may not reflect the way batteries are used in 
RBR instruments, and thus, are not always informative.

Autonomy figures depend on the power draw of the instrument, as well as the derated capacity of the battery pack. 
Batteries are derated to 4°C. These values differ for different battery chemistries. For the most accurate deployment 
estimates, select the same batteries from the dropdown menu as installed in your instrument. 

Ruskin calculates the expected battery usage for the instrument during setup . The nominal capacity of each type of 
battery is described  in the Power section and is given in mAh at room temperature. Battery voltage does not decrease 
linearly and is therefore not an accurate indicator of battery capacity.

RBR tested batteries of various brands at 6°C; all of them were able to provide the threshold capacity defined in the 
Power section. View these predictions and further de-rate the batteries if the expected deployment is in cold water. 

The software will warn you if the expected battery usage for a particular deployment scenario is approaching the 
theoretical potential mAh.

The software will not prevent your instrument from being started even if a warning is given. However, adjusting 
deployment parameters or replacing the batteries may help extend deployment times. 

7.3 Power

The Power section includes battery chemistry options. 
 Ruskin autonomy engine uses these parameters to 
estimate deployment life.

The Battery dropdown menu shows available chemistry 
options for internal batteries. The list depends on your 
instrument.

RBR ships all new instruments with batteries of the highest capacity for the instrument type already installed. 

RBR instruments can use most chemistries of AA batteries.

Typically, RBR instruments are shipped with EVE ER14505 lithium thionyl chloride or Energizer L91AA lithium iron. 
Select your battery chemistry from the dropdown list.

Mixing batteries of different chemistries, brands, and age will reduce performance and potentially damage the 
instrument. Improperly matched batteries may become overheated, leak, or even explode.

Lithium thionyl chloride batteries are only recommended for T, D, and T.D instruments. Other sensors will not 
work correctly on this type of battery.
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Battery chemistries

Name Chemistry Voltage (V) J*

Lithium thionyl chloride Li-SOCl2 3.6 30,300

Lithium iron Li-FeS2 1.5 14,510

Alkaline Zn-MnO2 1.5 10,130

Li-ion Li-NiMnCo 3.6 7290

Nickel metal hydride Ni-MH 1.2 7340

*The nominal capacity of each type of battery is given at room temperature. 

Deployment estimates

Ruskin estimates autonomy figures based on the power draw of the instrument, as well as the derated capacity of the 
batteries. Batteries are derated to 4°C . These values differ for different chemistries (see above). For the most accurate 
deployment estimates, select the same batteries from the dropdown menu as installed in your instrument. 
Alternatively, use Ruskin to simulate your instrument with different batteries and find which chemistry works best for 
your deployment.

7.4 Scheduling cards
The Scheduling cards represent the sensors on the instrument, so each sensor will have a separate card allowing each 
sensor to be scheduled independently.

Each card includes a Mode field, as well as several 
optional fields available with certain sampling modes. If 
the fields are not visible click anywhere on the card to 
expand it.

To schedule a sensor ensure the checkbox next to the 
sensor name is selected.

When connecting an RBRsolo4 x or RBRduet4 D.x, Ruskin select Discover sensors to request Ruskin to search for the 
correct sensor.

Battery cells of the same chemistry but from different manufacturers may have different performance.  If the 
nominal capacity of the battery model you are using is lower than outlined above, your actual deployment 
may be shorter than the estimate.

Replace batteries before each deployment to maximise the operational time and prevent data loss.
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Mode

Depending on your instrument, different dropdown options may be available. See Tide and Wave for information on 
how to configure these modes. 

Speed and Rate

These are the only two parameters you need to configure Continuous sampling mode.

Check Period to select the sampling Rate in Hz from the dropdown menu. The default option is always the highest 
instrument rating. For example, | fast32 will default to 32Hz.

Uncheck Period to enter the sampling Rate manually in hours, minutes, and seconds (HH:mm:ss format). The fastest 
rate to enter manually is 1s. Type the numbers in, or use the up and down arrows.

7.4.1 Tide

Tide sampling mode collects data at a certain rate, and then averages those samples to produce a single value to store 
on the instrument. When set to Tide, the instrument uses averaging to remove wave noise data from pressure 
measurements.

In addition to Rate, there are two more parameters required for Tide mode: Measurement duration and Period. 

Measurement duration specifies the time range over which to average. It must always be longer than Rate.

Period is the repetition period for performing the averaging. It must always be longer than Measurement duration.

Sampling controls

Select Rate from pre-defined options in the dropdown 
menu. Then manually enter the Measurement duration
and Period

In the example shown, the sampling rate selected is 32Hz (32 samples per second). The instrument will be logging for a 
duration of one second, then pause and average the sixteen samples collected. After an interval of five minutes, it will 
start logging again, repeating the same cycle. 

7.4.2 Wave

Wave sampling mode collects a specified number of samples at a specified rate, and repeats this operation at a 
specified interval. When in Wave mode, the instrument takes multiple pressure readings in a burst and reconstructs the 
surface wave time series. This mode records both tide and wave information. 

All  | tide and  | wave instruments can sample at rates of 2, 4, 8, 16, or 32Hz.

All instruments with the | tide32 and | wave32 features support Tide sampling mode. 

At every Period, the instrument records only one sample, averaged over all samples collected during the 
period of Measurement duration. The rest of the samples are discarded after averaging is performed. 

Only instruments with the | wave32 feature support Wave sampling mode. 
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Measurement period or Rate are parameters defining individual pressure readings. 

 The highest possible frequency visible in the data is limited to ½ the sampling rate. However, this mathematical 
limit cannot be achieved because of wave attenuation, and real data are actually lower. 

 The sampling rate defines the resolution of the frequency spectrum which can be calculated from the wave 
data. 

 The sampling rate, together with the burst duration, defines the lowest frequency which can be assessed in a 
wave burst.

In addition to Measurement period and Rate, there are two more parameters required for Wave mode: Measurement 
Duration and Period. 

Measurement duration specifies the number of samples to record.

Period is the repetition period for performing the burst. It must always be longer than the time it takes to obtain 
the number of samples indicated in Measurement duration.

Furthermore, you may enter Instrument altitude and Mean depth of water to estimate possible wave periods for your 
deployment. These parameters are not mandatory for the instrument to work, but allow you to get an idea of what to 
expect. 

 Instrument altitude is the actual height of the instrument in metres above the seabed. This is defined by 
deployment requirements, and the instrument must be physically affixed at this height during the installation.

 This parameter is stored on the instrument and used to compute wave statistics for pre-deployment 
analysis.

 Mean depth of water is an estimate of the average water depth in metres, used for the initial prediction of wave 
frequency. It must always be greater than Instrument altitude. 

 This parameter is not stored in the logger and only used to compute wave statistics. It is adjusted post-
deployment through the RSK file.

 Ruskin will calculate the actual mean depth of water from the instrument altitude and its depth 
measured during the deployment. 

Sampling controls

Select Rate and Measurement count from the drop-down menus, and enter Period manually. For example, with a rate 
of 4Hz and a duration of 4096 samples, the instrument will be sampling 17 minutes 4 seconds. You can set up near 
continuous sampling by setting the interval to 17:05. Logging will be on every second except the one remaining second 
of the interval, and then start again. 

Consider unique aspects of deployment environment when setting up Wave sampling mode.
For example, while a 30-minute interval tends to work in most cases, shorter intervals may suit better when 
encountering ocean swells which have longer wavelengths than noise but shorter than tide. 
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Enter Instrument altitude and Mean depth of water
manually. Estimates for wave statistics will be 
immediately displayed: maximum wave frequency and 
minimum wave period (essentially, they reflect the same 
concept because period = 1/frequency). These values can 
be adjusted post-deployment through the RSK file.

Deployment depth of | wave32 instruments

Attach your  | wave32 instrument to a suitable support below the surface of the water, such as a dock or other rigid 
mooring, to completely immobilise it.  

Enter the expected mean depth of water and the known instrument altitude (height above the seabed). From these 
values, Ruskin will estimate wave frequencies and wave periods that your instrument could measure (period = 1/
frequency). On data retrieval, Ruskin will calculate the actual mean depth of water from the instrument altitude entered 
and its depth measured using the pressure transducer, and then use this actual depth for computing all wave statistics 
during deployment. 

The physics of what a pressure transducer can measure depends on the height of water above as well as the depth of 
water below it. High frequencies attenuate very quickly with depth. The depth of the deployment is critical in 
determining frequencies/periods of the wave data the instrument will be able to capture. It is the depth, not orientation 
of the pressure transducer that affects these measurements.

 Instrument fixed to a dock below the water surface
 Wave attenuation as a function of depth for various wave 

periods

The timestamp of the burst for both Tide and Wave datasets is the beginning of the burst.

The basic rule is to place the instrument as close to the surface as possible without it emerging from the water 
due to large waves or low tides.
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7.5 Download latest
There is a button on the Deployment tab labelled Download latest. This button downloads the latest dataset stored in 
the instrument. This dataset could be still recording.

Steps

1. Click Download latest. The file is automatically downloaded to the location specified in Settings > General, and 
names it as it appears in the Datasets tab.

2. The new dataset will appear automatically in Navigator window under Datasets. 

3. The Properties window will change to the dataset view, with the following tabs: Overview, Analysis, and 
Channels.

4. All the data stored on the instrument at the time of the download will be automatically plotted in the Plot
window.

When you download data again while on the same schedule, the RSK file will append it with any new data stored since 
the last download. This default behaviour can be changed in Ruskin > Settings > General > Download options.

7.6 Enable / Stop
Ensure that your instrument is ready to be deployed before enabling a schedule. See Deploy your instrument. 

To allow the instrument to start logging, click 
Enable. This button is at the bottom left of 
the Deployment tab.  

RBR recommends storing your data on a local drive ratherthan a network storage drive. Cloud storage options 
such as GoogleDrive and Dropbox may extend download times.

https://docs-rbr.atlassian.net/wiki/spaces/RUSKINGEN4/pages/692879362/Datasets
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The Enable button will now read Stop. The status will 
become "Deployment paused", "Deployment gated", or 
"Sampling in progress", depending on the configuration. 

Logging will start when one of the following occurs:

 The Now button is checked

 The Start time arrives

If the maximum number of deployments have been recorded, you will not be able to click Enable.

Before proceeding, download the data from your instrument (see Download).

To manually stop the instrument, click Stop.

Logging will stop on its own when one of the following occurs:

 The End logging time is reached

 The power source is removed or depleted

 The memory is filled

All editable fields become greyed out after you enable a schedule. 
To change any deployment parameters, stop your instrument, adjust the settings, and start a new 
deployment.
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8 Calibration
Under the Calibration tab you can confirm measured and derived parameters for your instrument.  It also displays 
calibration coefficients for each parameter, the date and time of the last calibration, and all the parameters the RBR 
instrument may need for calculating derived channels. Select a sensor from the table to display its calibrations.

If you see a warning sign on the Calibration tab, this indicates that the calibration is out of date and needs to be 
recalibrated.

RBR calibration certificates contain calibration equations, coefficients, and residuals for each sensor.

The date of the latest calibration is always displayed. A warning sign will appear on the tab when your calibration 
certificate is out of date. 

RBR recommends calibrating your instrument before any critical deployment, periodically once a year, or if you suspect 
the readings to be out of specifications. 

Discuss your calibration requirements with RBR. In some cases, the instrument may need to be returned to RBR to have 
it checked and recalibrated.

To contact RBR for our current calibration fees, click Request calibration quote and complete the Request for quote 
form.

Calibration controls

You can edit the calibration coefficients, displayed as "C" values: C0, C1, C2, C3. As soon as you make a change and 
move to another cell, a new calibration date will be displayed. Also, Save and Undo buttons will become active. 

Use Save to save the new values.

Use Undo to recover to the original coefficients if you have not already saved your changes to the instrument. 

Always click Save to save new coefficients on the instrument. Otherwise, all changes will be lost once your 
session is closed. 

You cannot use Undo after clicking Save. Once the coefficients are saved to the instrument, you will need to 
restore old values manually and save them again. 

mailto:support@rbr-global.com
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Parameters

The Parameters table displays all the parameters the RBR instrument may need for calculating derived channels.

If your instrument can measure a parameter, it will use the measured value. Otherwise, you can enter the necessary 
values manually, and they will take effect immediately. 

For example, you always need atmospheric pressure and water density for derivation of depth. Default values in Ruskin 
correspond to sea level and sea water. Therefore, it is especially important to adjust these parameters when working at 
high altitudes in fresh water.

Enter atmospheric pressure (in dbar) and water density (in g/cm3) manually in the table under the Calibration tab. If 
not entered, default values of 10.1325dbar and 1.0281g/cm3 will be used. 



RBR#0020213revA 32

9 Settings
On your Mac, access Settings from the Ruskin dropdown 
menu in the top toolbar.

On your Windows PC, use the Options dropdown menu 
to set up your preferences. 

Factory-set global defaults require no changes in most situations. However, as you learn more about what Ruskin can 
do, you may want to change some of these settings to better suit your requirements. The global preferences include:

 Derived channels (applies to some legacy instruments)

 Facility (authorised users only, requires login)

 General (download locations and options, sampling and calibration controls, export options)

 Plotting (channel visibility and channel colours)

9.1 Derived channels

.The Derived Channels section of the Preferences dialog box has four tabs:  Depth, Conductivity - Salinity, Dissolved 
O2, and No sensor values, where you can choose additional channels derived from measured channels. 

Derived channels calculated by the instrument as well as those calculated by Ruskin are automatically added to the 
default channel list in both the live Plot view and the static dataset.

Depth

If your instrument has a pressure channel, you can use its measurements to derive a depth channel. The data calculated 
for this derived channel appear along with measured channels in the Plot view and in datasets.

1. Select the Enable Depth Channel checkbox.

2. In the Atmospheric Pressure box, type the value in dbar or use the default value. This value corrects the 
pressure measurements during the depth calculation.

The Derived channels settings are intended for XR(X),1060, 2050, and 1050 RBR legacy data loggers. They do 
not apply to newer generations. They do not apply to any RBRcoda or RBRcoda3 instruments.
Newer generations calculate all possible derived channels for that specific instrument.
Use the Calibration tab in the instrument Properties window to set up initial parameters for calculating 
derived channels.
For downloaded files, use the Parameters tab in the dataset Properties window.

For newer generation instruments, all derived channels are calculated regardless of the checkbox 
status.

https://docs-rbr.atlassian.net/wiki/spaces/RUSKINGEN4/pages/692879362/Datasets
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3. Select either the Simplified calculation or Seawater calculation.

a. To use the simplified calculation, type the actual water density, or use the default value. Note that for 
freshwater, the density should be set to 1.0.

b. To use the UNESCO seawater calculation, specify the latitude of the data collection in degrees and 
minutes.

Dissolved O2

You can derive a dissolved oxygen channel that measures oxygen saturation as a percentage. 

1. Click the Dissolved O2 tab and select the Enable Dissolved Oxygen Channel checkbox.

2. If your instruments use the Oxyguard DO or RINKO DO sensor, select the Derive concentration using the Weiss 
equation checkbox and the output unit: µMol/L, mg/L, or mL/L.

3. If your instruments use the Aanderaa Optode DO sensor to measure oxygen saturation, select the Derive 
concentration using the Weiss equation checkbox and the output unit: mg/L or mL/L.

4. If any of your instruments use the Aanderaa Optode DO sensor to measure oxygen concentration, select the 
Calculate saturation using the Garcia and Gordon equation checkbox.

No sensor values

Enter salinity, pressure, and temperature values used to calculate the derived channels when a sensor is not available.

The default Atmospheric Pressure value is 10.1325. Adjust this value manually to represent a different 
altitude.

Ruskin can calculate depth based on the simplified calculation or the UNESCO seawater calculation. 
The instrument always calculates depth using the simplified calculation.

The Conductivity - Salinity tab is only relevant for legacy standard instruments with a conductivity sensor. It 
does not apply to legacy compact instruments.

For newer generation instruments, all derived channels are calculated regardless of the checkbox 
status.

The Weiss equation requires values for temperature and salinity. If your instrument does not measure 
them, you can specify standard values on the No sensor values tab.

The Garcia and Gordon equation requires values for temperature and salinity. If your instrument does 
not measure them, you can specify standard values on the No sensor values tab.

If you suspect that the derived channel value is incorrect, check to make sure that the No sensor values
entries match the deployment environment.
For example, if a dissolved oxygen saturation measurement is made in a lake at 8ºC but the No sensor values
salinity is 35 and the temperature is 15ºC, concentration reported will be incorrect.
Adjust the No sensor values entries and recompute.
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9.2 General
Use the General settings page to set up file locations, language, download options, sampling and calibration controls, 
and export options. 

File location

You can control where RSK files, realtime RSK file, and log files are stored by default. 

Specify these locations before downloading any data by typing in a directory name or by browsing. 

RSK files are the datasets obtained from your instrument. 

Realtime RSK files are generated when a connected instrument is streaming or when you enable fetching mode on the 
instrument.

Log files are generated by Ruskin and help when diagnosing issues. These files are automatically attached to issues 
generated using the Comment on Ruskin feature.

You can change where future files are stored by default at any time. When done, click Apply or Apply and close.  The 
changes will take effect immediately.

Language selection

Ruskin is available in six languages: English, French, Spanish, Simplified Chinese, Korean, and Japanese.

Select your language from the dropdown menu and click Apply or Apply and close. Ruskin will need to restart for the 
changes to take effect. 

You can click Apply to save your changes without closing the dialogue box.

RBR recommends storing your datasets on a local drive rather than a network storage drive. Cloud storage 
options such as GoogleDrive and Dropbox may extend download times.

https://docs-rbr.atlassian.net/wiki/spaces/RUSKIN/pages/17432641/Comment+on+Ruskin
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Download options

Select the appropriate checkboxes to change your download preferences.

When done, click Apply or Apply and close.  The changes will take effect immediately.

Export options

Select the checkbox to enable raw data export. Use this option for downloading your RSK file when storage space is 
limited or expensive. The dataset will be exported in the most compact raw binary format. 

When done, click Apply or Apply and close.  The changes will take effect immediately.

9.3 Plotting
Adjust default settings for the graphical display in the Plot view. Manage selections in Channel visibility and Channel 
colours, and apply them globally.

Channel visibility

The Channel visibility tab displays many options to hide or show specific information.

Opt for displaying errors and events for a more informative graph, or hide them for a cleaner view. 

Select the By default, hide all measured channels checkbox to display only derived channels.

Select the By default, hide all derived channels checkbox to display only measured channels.

Otherwise, pick and choose channels to display or hide. 

When done, click Apply or Apply and close.  The changes will take effect immediately.

Channel colours

The Channel colours tab allows you to choose a different colour for each channel that is shown for information 
currently running in Plot view, or from an opened dataset. Select from the list of pre-defined options or create your own 
colour.

When done, click Apply or Apply and close.  The changes will take effect immediately.

The Enable download schedule UI checkbox is only for legacy instruments.

You can click Apply to save your changes without closing the dialogue box.

You can override visibility preferences in the Plot view for any particular graphical display.
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10 RSK files
The RSK file is a single file database based on SQLite that allows us to have large files with high-speed access to any part 
of the dataset. RSK files have different types and versions, which reflect historical changes to the underlying dataset 
structure. To upgrade the version of an older RSK file, go to Overview tab. 

RBR provides open-source RSKtools toolboxes for both Matlab (RSKtools) and Python (pyRSKtools) to read, post-
process, visualise, and export RSK files.

RSK files can be exported to Excel, OceanDataView®, or text files.

RSK files contain data recorded by the instrument or sensor, firmware and software versions, dates and times, sampling 
settings, power settings, measured and derived parameters, errors and events, other diagnostic information. 

For datasets obtained via streaming or polling, the RSK format is Realtime. Their file names contain the "realtime" 
label. 
This file format is available for RBR standard instruments and RBR realtime sensors when in streaming mode, and for all 
instruments when polling. 

To identify the type of the RSK file, go to the Overview tab.  

File naming convention for datasets obtained during deployments

By default, RSK file names are composed of the following information:

 The instrument serial number: six digits

 The date of the deployment (YYYY-MM-DD): eight digits

 The time of the deployment (HH-MM in the 24-hour format): four digits

For example, the file named 209681_20260204_1306.rsk contains the dataset for an instrument with a serial number of 
209681; the start time of the deployment was February 04, 2026 at 13:06 (01:06pm), local time. 

The data recorded from the current and previous deployments are stored in the instrument. They can be accessed 
(downloaded or deleted) from the Datasets tab. You can also download the latest deployment from the Deployment
tab. Download them to your computer before starting a new deployment. Go to Preferences > General to change your 
default location for RSK downloads.  

File naming convention for realtime datasets

By default, realtime dataset names are composed of the following information:

 The instrument serial number: six digits

 The date of the download (YYYY-MM-DD): eight digits

 The time of file creation (HH-MM in the 24-hour format): four digits

 The "realtime" label, indicating the data were streamed or fetched from the instrument

For example, the file named 209682_20260205_1408_realtime.rsk contains the dataset for a streaming instrument with 
a serial number of 209682; the data collection started on February 05, 2026 at 14:08 (02:08pm), local time.

Datasets recorded in Calibration storage format allow changes to calibration coefficients. You must explicitly 
select this option if you wish to manipulate calibration coefficients after the data has been recorded.

GPS mapping for RSK files relies on manually added location points.

RBR recommends downloading deployments as soon as possible to ensure data is recorded in a safe location.

http://rbr-global.com/support/matlab-tools
https://docs-rbr.atlassian.net/wiki/spaces/GEN4CR/pages/13828175/General+overview
https://docs-rbr.atlassian.net/wiki/spaces/RUSKINGEN4/pages/692879362/Datasets
https://docs-rbr.atlassian.net/wiki/spaces/RUSKIN/pages/17432806/Download
https://docs-rbr.atlassian.net/wiki/spaces/RUSKIN/pages/17432841/General
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The data streamed or polled from your instrument are automatically saved to your computer. Go to Preferences > 
General to change your default location for realtime RSK files.  

The file extension is .rsk; it indicates the Ruskin file format and must not be edited. If you change it, your new 
file extension will become part of the dataset name, and the .rsk extension will be appended.

https://docs-rbr.atlassian.net/wiki/spaces/RUSKIN/pages/17432841/General
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11 Dataset files
Datasets are RSK files generated by Ruskin and have an .rsk extension. After downloading your datasets, you can view 
and analyse your data using the options below. 

Go to the File dropdown menu to open or close a 
dataset, export your data, and see the list of available 
datasets. 

The Datasets context menu in the Navigator windows 
duplicates some of these options for convenience.

When a dataset on the list is selected, 
the Properties window displays three tabs with 
information related to this dataset.

Use these tabs to analyse your data, check the 
calibration certificates, and verify your parameters. 

11.1 Open dataset
Open any stored dataset from the File menu in the top toolbar or from the Datasets menu in the Navigator view. 

Steps

1. Select File > Open dataset

Alternatively, right-click Datasets in the Navigator
view and select Open dataset.

https://docs-rbr.atlassian.net/wiki/spaces/RUSKIN/pages/17432802/RSK+files
https://docs-rbr.atlassian.net/wiki/spaces/RUSKIN/pages/17432806/Download
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2. A browsing window will appear. Double-click 
the .rsk file you want to view, or select the file and 
click Open. 

3. The name of the dataset appears and is 
highlighted automatically in the Navigator view. 
The Properties view changes to the dataset view, 
with four tabs: Overview, Analysis, Channels, 
and Calibration. It will open to the Analysis tab 
by default.

4. The data in the file will automatically appear in 
the Plot view.

11.2 Export
Use the Export option to share your data with others or analyse your data using other software. Datasets can be read 
directly in Matlab with our toolkit RSKtools, or exported to Excel, OceanDataView®, or text files. 

Steps

1. File menu > Export, then hover to open a set of submenus.

To close a dataset, go to File > Close dataset. Alternatively, right-click the dataset name in the Navigator view 
and select Close dataset. 
 Alternatively, simply close its Plot tab by clicking the X. The dataset will disappear from the list.

http://rbr-global.com/support/matlab-tools
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or right-click the dataset in the Navigator window, then hover to open a set of submenus.

2. Select the appropriate export format (Microsoft Excel, netCDF/netCDF profiles, Text, OceanDataView 
spreadsheet, or Raw binary). 

3. If exporting annotations, select the category: Full profiles, Downcasts, or Upcasts.

4. Specify a location and a name for the data file. 

5. Click Save.

11.3 Analysis
Select a dataset in the Navigator view.

The Properties view will change to dataset properties, 
with three tabs: Overview, Analysis, and Channels.

The Analysis view contains statistical information about 
deployment, as well as information about the dataset 
channels and their values. 

The colour-coding of the channel table matches that of 
the traces in the Plot window. To change the colour 
settings for your chart, go to Preferences > Plotting > 
Channel colours.  

Move the black cursor ("double lollipop") in the Plot window to display parameter values for each sample selected.

Every time you move the black cursor, going from sample to sample, the table above the plot will display the 
information for this particular sample.

For realtime RSK files, the Raw binary export format is not available.

https://docs-rbr.atlassian.net/wiki/spaces/RUSKIN/pages/17432654/Plotting
https://docs-rbr.atlassian.net/wiki/spaces/RUSKIN/pages/17432802/RSK+files
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Select Display statistics checkbox to determine the average value and standard deviation over a range of samples. 
Change the selected time range of samples to average using the up and down arrows or by clicking in each of the hour, 
minute, and seconds fields to edit the time manually.

The table will display the averaging data. The averaging interval will be highlighted in the plot.
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11.4 Overview
Use the Overview tab to view general information for each dataset, including instrument firmware and serial number, 
enabled schedules, deployment events, and details about the file itself. 

11.5 Channels

For, non realtime datasets, the Channels tab will have 
three options:  Information, Calibration, 
and Parameters. 

For realtime datasets, the Channels tab has two options: 
Information and Parameters. 

The Information page displays two tables: Measured 
channels and Derived channels.

Measured channels include measured parameters with 
their units of measurement, the sensor manufacturer, 
and the range setting (if applicable). 

Derived channels include all available derived 
parameters with their units of measurement and the 
methodology used to calculate them.



RBR#0020213revA 43

The Calibration page displays the calibration and 
correction coefficients (as applicable) for each channel, 
along with the date and time of the last calibration.

Select a sensor from the Parameter dropdown menu to 
display its calibrations.

The main calibration coefficients are displayed as "C" values: C0, C1, C2(K). Dependent coefficients are displayed as "X" 
values: X0, X1, X2, etc.

As soon as an edit is made to a coefficient cell and 
another cell is selected, a new calibration date will be 
displayed. Also, all three buttons at the bottom of the 
page will become active. 

Use Store and recompute data to recalculate the 
dataset. Use Revert calibration to restore the previous 
coefficients that were not saved.

To restore the calibration used during the deployment, if 
a new calibration has been stored, check the Use 
deployment calibrations checkbox.  Click Store and 
recompute data to save the coefficients as the latest.

The Parameters tab displays parameters necessary to 
calculate derived channels and the method used for 
calculation.

You can edit these parameters to change the derived 
channel calculation. As soon as you make a change, the 
two buttons at the bottom of the page will become 
active. 

Click Update and recompute to recalculate the data and 
display new values. 

Use Revert settings to recover the previous coefficients 
and data if you have not already selected Update and 
recompute. 

Both offset and slope are editable in any dataset format. Other coefficients are only editable when recorded in 
calibration mode.

This page is not editable for realtime datasets. 
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12 Dataset plot toolbar
Use the plot toolbar to adjust the display of an open dataset. 

12.1 Annotation controls
Annotations are information messages added either by users or by the instrument. 

12.1.1 Select annotation type
Annotation types are divided in two categories: profiling (Profile, Downcast, or Upcast) or non-profiling (Comment, 
Exclusion, Location, or Calibration). Use annotation controls to manage this information and to navigate the plot. 

Type Function

Profile, Downcast, Upcast Identify profiling

Comment Add a note to your data

Exclusion Remove a non-representative interval from analysis

Location Add in latitude/longitude coordinates for RSK files to track locations of data 
logging

Calibration Calibrate the ODO sensor

https://docs-rbr.atlassian.net/wiki/spaces/RUSKIN/pages/17432976/ODO+calibration+in+Plot+window


RBR#0020213revA 45

Open the Filter dropdown menu to select the annotation 
type to display. The number of annotations for each type 
will be indicated. 

Select an annotation type. The plot will centre on the first item in the selected category. For example, when you select 
Profile, the plot will move to the first profile. 

If you switch the filter to another annotation type within the same category (for example, Profile to Upcast), the plot 
will not change. If you switch to a type from another category (for example, from Profile to Comment), the plot will 
move to the first annotation in the new category (for example, to the first comment). 

12.1.2 Navigate between annotations

Use the Navigation buttons  to navigate between items within the selected category. 

Navigation controls

 Move from one annotation to another by clicking the left and right arrows.

 Jump all the way to the beginning or end of the list by using the end-left and end-right arrows.

 Alternatively, manually enter the number in the Index field to go to that particular annotation. 

 Double-click an annotation to centre and zoom in the plot at that particular area. 
.

12.1.3 Create new annotation

Click the Create annotation button  and follow the steps below. 

The navigation buttons will be activated if there is more than one item in the selected annotation type. 
Otherwise, the plot will centre on the only item available. 

Double-click anywhere on the main plot to return to the full-chart view.
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Steps

1. Select the type of annotation to create, for 
example, Comment.
The cursor in the Plot window will become a two-
way arrow .

2. Click on the main plot to identify a single point to 
comment, or click and drag the cursor left or right 
to select an interval. When you release the click, 
an editable tooltip will open.

The tooltip controls include Left and Right arrows  , Delete  , Export region  , Save  , and 

Close  . 

The Profile tooltip also features Up and Down arrows  for adding upcast and downcast profiles. 

3. Enter the necessary information into the fields 
and save by pressing Enter on your keyboard or 

by clicking Save   on the tooltip. Your new 
comment will appear in the dropdown list.

 Clicking Close   or pressing Esc on the keyboard will close the tooltip without saving. 

 Click the arrows  on the tooltip to move to the next annotation within the same category. 

 Double-click on the annotation bar to zoom in to the range of the annotation. 

 Click and drag on the annotation bar to move the annotation. 

 Click Delete   on the tooltip to delete the annotation. A warning message will appear. 

 Click Delete to proceed. This action cannot be undone.
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12.1.4 Add profiles
Use the Annotation function to manually add profiles to your dataset.  

Steps

1. Click the Create annotation button 

 and select Profile from the dropdown menu.

2. Click and drag the cursor to select a region.  
As soon as you let go, an editable tooltip will open 
and a band of a darker colour will appear above 
the selection, indicating that a new profile has 
been added.

3. Place the cursor on the edge of this new profile 
and move it left or right to adjust the size. 

4. Add a name and click Save  on the tooltip. 

Edit at least one detail in the tooltip before saving. Otherwise, the annotation will be deleted when 
deselected.  Moving or resizing the annotation counts as editing and saving.
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5. Use the Up and Down arrows  on 
the tooltip to identify upcast and downcast 
regions.
The upcasts and downcasts you added will be 
displayed in the dropdown menu and highlighted 
on the plot under the parent profile.

6. Place the cursor at the edge of the added region 
and adjust its size.

7. Click on a profile/upcast/downcast to open its 
tooltip.  

8. Name each region and save the settings. 

9. If desired, export your profile to a separate RSK file. To do that, click Export region  on the Profile tooltip 
and follow the steps.

12.1.5 Export region

Follow the steps below to clip your dataset and export a subset of your data. This function may be useful when you 
need to exclude certain regions. For example, a dataset may contain several deployments if sampling was not paused/
stopped before the new deployment was started. 

Only the Profile tooltips have the  Up and Down arrows.

The Export region option is not available on Upcast and Downcast tooltips. To generate an RSK file for an 
upcast or downcast section only, use the Comment annotation to clip the dataset before exporting.

The Export region option is only available for Comment and Profile annotations. 
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Steps

1. Click the Create annotation button  and 
select Comment from the dropdown menu.

2. Click and drag the cursor to select a subset. 

3. Enter a name in the Title field on the tooltip and 

click Save  . 

4. Select Export region   on the tooltip.
A dialogue box will open. 

5. Adjust the name and location for the new dataset 
file and click Save.  
An Export region message will appear. 

6. Select No to maintain the full binary values and 
retain the option of recalibration in the future. 
The clipped dataset will open in a new tab in the 
Plot window.
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12.2 Cast detection
Ruskin automatically enables profile detection on instruments when a deployment is enabled. There are several criteria 
for enabling this feature.

  The instrument must support the castdetection  setting

  The instrument must have a pressure sensor

  The deployment must be configured for | fast sampling (2Hz and up)

  The deployment mode must be configured as either continuous or directional

It is possible to recalculate the casts in a dataset using the cast detection feature in the Plot view. 

Click the Cast detection button  to run a cast detection algorithm based on depth and conductivity to 
automatically generate profiles and casts. A warning message will appear.

If you proceed, Ruskin will find peaks, collect events, and overwrite profiles recorded by the instrument. .

12.3 Event visibility

Click the Event visibility button  to turn on and off the visibility of the various levels of events: Error, Warning, 
Information, and Diagnostic. Its colour will reflect the highest level of event severity reported. 

Double-click anywhere on the main plot to return to the full-chart view.
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12.4 Zoom controls
Default scaling of the plot is based on the minimum and maximum values sampled for each channel. Use zoom controls 
to adjust it as needed. 

12.4.1 Horizontal zoom
Horizontal scale options may be helpful to increase or decrease the the time range displayed. It is convenient when the 
dataset is long and thus losing resolution when displayed in the Plot window in its entirety, like in this example. 

There are three ways to apply changes to the horizontal scale.  The first two will auto-range your chart, ensuring the 
entire vertical domain is visible. The third approach will retain the latest vertical scaling of the original interval. 

1. Use the Zoom in horizontally and Zoom out horizontally buttons. 
 OR
Click on the thumbnail view and resize the indicator. The vertical scale will automatically adjust to fit the new 
range.

Double-click anywhere on the main plot to return to the full-chart view.



RBR#0020213revA 52

2. Hover your mouse over the X-axis, then hold Shift + left click.
    The cursor will change to a two-way arrow . Drag it right to zoom in or left to zoom out the time domain, 
without changing the data resolution.

12.4.2 Vertical zoom
Vertical scale options may be helpful when there are erroneously high or low values that make the real data appear 
incorrect, or when there is significant difference in scale between the displayed parameters.

Entire chart

Depending on the zooming method, you may change the scale only vertically, or both vertically and horizontally. 

 Use the Zoom in vertically and Zoom out vertically buttons to increase or decrease the resolution of the data 
displayed.
The resulting display will retain the same horizontal scale. 

 Hover the cursor and scroll your mouse wheel up and down to change the scale.  
In this case, the horizontal scale will also change (as seen from the thumbnail indicator). The plot will centre 
where the mouse cursor initially was. 

Click Reset zoom to maximum bounds  or double-click anywhere on the chart to restore the original 
appearance. 
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Individual channel

There are two ways to apply changes to the vertical scale of one channel only, which yield the same results.

 Hover the cursor over the Y-axis for this channel and scroll your mouse wheel up and down.

 Shift + click the Y-axis for this channel and move your mouse up and down.

This particular channel will zoom in and out (in the example below, temperature).  Double-click on the same vertical 
axis to reset this parameter. 

12.4.3 Navigation options
After you change the scale, some parts of your chart may end up outside the Plot window. There are several options 
available to navigate it. 

 To pan the entire chart horizontally, hold Ctrl + left click and move your mouse left and right. This action is only 
possible after already applying some horizontal zoom to the chart.

Click Reset zoom to maximum bounds  or double-click anywhere on the chart to restore the original 
appearance. 
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 To pan the entire chart vertically, hold Ctrl + left click and move your mouse up and down.

 To pan one of the channels vertically, click a value on the vertical axis for that parameter (in the example below, 
sea pressure) and move your mouse up and down.

Double-click on the same vertical axis to reset this parameter. 

 To freely select any part of the chart, hold Shift
+ left click and draw the rectangle. The chart will 
zoom in on the selected area, both horizontally 
and vertically. 

 To keep all  your data within the viewing window, click the Toggle auto-ranging button .  When it is on, all 
profiles within the selected time section maintain their optimal vertical zoom. 
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 Click again to disable. Disabling the auto-ranging of the axis can be useful for looking at trends in data.
Zooming in or out of an individual channel will disable auto-ranging for that channel. 

 To zoom in to the range of an annotation, double-click on the annotation bar. 

12.5 Export plot

Click the Export plot button  and select file name 
and location to save the current view of the main plot to 
a PDF or PNG file. The exported file will contain the graph 
only and retain all the changes to display active at the 
moment of export: zoom, lines and markers, visible 
events and annotations, and plotting by depth or time.

12.6 Appearance controls

Select your data rendering type from the Change line type dropdown menu :  Lines, Markers, or Lines and 
markers.

Click Reset zoom to maximum bounds  or double-click anywhere on the chart to restore the original 
appearance. 
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Use the Toggle channel visibility button  to open 
the dropdown menu with the list of available channels 
and options. Check and uncheck channels to display as 
desired, or select groups to show and hide. 

Select Show raw channels to display measured data 
with no calibration equations applied. 

By default, the data are plotted by time. Use the Toggle depth plot  button to switch to the plot-by-depth mode.

If no data appears in the Plot view, try changing the rendering to Markers.  Time spans that are larger than 
expected will cause breaks between data points and lines will not be drawn connecting those points, whereas 
markers draw at each individual point.
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The thumbnail view will continue to display the plot-by-time data. 

12.7 GPS map

The Show GPS map button  opens a pop-up window with the GPS map for the plot. Click on the map to display all 
the GPS location annotations recorded in the dataset.

.

GPS mapping for Desktop RSK files relies on manually added location points (see Annotation controls). All location 
points you added using the Annotations feature are stored in the dataset file and can be displayed in Ruskin via the 
mapping functionality.

If there is no depth channel, the plot will use the next pressure or pressure-derived channel starting from the 
bottom of the channel list.



RBR#0020213revA 58

13 Plot window
Use the Plot window to view graphical displays of your datasets or live data. When viewing live data, the instrument 
must be attached.  

Each channel appears as a different colour in the plot. These colours are specified under Settings > Plotting and can be 
changed only there. 

Move the black "double lollipop" cursor from one sample to the next to display parameter values for each sample 
selected. Drag it with your mouse, or use the arrow keys on your keyboard as follows:

 To move by one data sample, press right or left arrow 

 To move by a hundred of samples, press Shift + right arrow or Shift + left arrow

 To move by ten thousand of samples, press Alt + right arrow or Alt + left arrow

 To move by millions of samples, press Shift + Alt + right arrow or Shift + Alt + left arrow

For the datasets, these values will appear in the Properties window above (see Analysis).  For live data, they will be on 
the side of the plot.

The graphical display for each dataset or instrument will be in its own tab.  The dataset file name or the instrument 
model and serial number will appear at the top of the tab. Simulated instruments will have "sim" in front of their name. 

A toolbar at the top right of the Plot window contains various buttons to help you customise, explore, and export the 
graphical display. The buttons selection changes depending on what is displayed in the tab. Hover over a button to 
display its name and function. 

A downsampled representation of the dataset appears in the thumbnail view, along with an indicator of the current 
plotted time range. 

https://docs-rbr.atlassian.net/wiki/spaces/RUSKIN/pages/17432654/Plotting
https://docs-rbr.atlassian.net/wiki/spaces/RUSKIN/pages/17432874/Analysis
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Position the indicator by clicking on the thumbnail view and dragging the indicator. Resize the indicator by dragging the 
edges left and right. It will zoom the main plot along the time domain to match the new indicator size. See Zoom 
controls for more scaling options. 

When you close and re-open a dataset, it will retain your latest settings (channel visibility, zoom, plot style (plot-by-time 
or plot-by-depth), annotation selection, and display style (lines or markers).

Double-click anywhere on the main plot to return to the full-chart view.

.

The thumbnail view always shows the plot-by-time data, even if the plot is switched to the plot-by-depth 
mode.

Go to Appearance controls to change your selection of lines and markers. .

https://docs-rbr.atlassian.net/wiki/spaces/RUSKIN/pages/17432824/Zoom+controls
https://docs-rbr.atlassian.net/wiki/spaces/RUSKIN/pages/17432920/Appearance+controls
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14 Live data plot toolbar
You can use the Plot window to view a live graphical display of your instrument sampling. All options described in the 
Dataset plot toolbar section apply to live data display. Additionally, three live data buttons appear at the right end of 
the toolbar: Side data panel, Live plot time range, and Poll. 

Click the Sample display button  to toggle on and off the data panel to the right of the plot. It shows the file 
location that will be used to capture samples, the number of samples collected, the values of the last received sample, 
and the currently selected sample.  

Click the Live plot time range    button to open a 
dropdown list of time span options.

For example. select 2 minutes to display the data in the 
thumbnail view and on the side panel by two-minute 
time periods.

https://docs-rbr.atlassian.net/wiki/spaces/RUSKIN/pages/17432911/Dataset+plot+toolbar
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You can also choose to display all of the data collected.

Polling

Live data can come from one of two sources: streaming or polling. 

Polling is the action of asking the instrument to take a reading and report it. 

Click the Poll button  to start polling data. The button will change to Pause . Click the Pause button  to 
stop polling. 
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15 Firmware updates
Ruskin automatically checks if your instrument firmware is up-to-date. Updates may be critical, routine, or customised. 

15.1 Critical firmware updates
If a newer version is available and this update is critical, the Update firmware button and a warning message will 
appear at the top of the Deployment tab. 

Steps

1. Click Update firmware.
The Update instrument firmware window will 
appear. It will contain Release notes, outlining 
the new version number, its release date, 
improvements, and bug fixes associated with this 
release, and two standard buttons at the bottom 
of the window: Close and Proceed. 

2. Click Proceed to initialise the update.
The instrument will disappear from the Navigator
window during the upgrade. Watch the progress 
bar at the bottom of the window for the status. 

.If the upgrade does not complete successfully, go to Instruments > Update firmware…

The Update firmware window will appear. Click Proceed again to retry. 

If the instrument does not reappear in the Navigator window after a firmware update, disconnect your instrument from 
the USB port and then reconnect to establish communication.

15.2 Routine firmware updates
If the latest update is not critical, Ruskin will not display any warning message. However, you can always check 
manually if a newer firmware warning is available.

Do not disconnect the instrument until a confirmation message is displayed. Disconnecting during the update 
process may render the instrument inoperable.
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Go to Instruments > Update instrument firmware.

The Update instrument firmware dialog box will 
appear. In addition to the new version number, its 
release date, improvements, and bug fixes, there will be 
two additional sections: Select the instrument to 
update and Select the firmware image. 

Steps

1. From the Instrument dropdown, select the 
instrument you wish to upgrade.

2. From the firmware selection dropdown, select the 
latest firmware image.   

3. Click Proceed to initialise the update.
The instrument will disappear from the Navigator
window during the upgrade. Watch the progress 
bar at the bottom of the window for the status.

If the upgrade does not complete successfully, click Proceed again to retry. 

Do not disconnect the instrument until a confirmation message is displayed.
Disconnecting during the update process may render the instrument inoperable.
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If the instrument does not reappear in the Navigator window after a firmware update, disconnect your instrument from 
the USB port and then reconnect to re-establish communication.

15.3 Manual firmware updates
In certain cases, RBR may supply a customised firmware version, which will not be on the dropdown list. 

Go to the Instruments > Update firmware…

The Update logger firmware dialog box will appear.  Follow the steps below to import the firmware image provided by 
RBR and update your firmware. 

Steps

1. In the Update logger firmware dialog box, click 
Import.

2. Browse to the location of the firmware update file. 
The file will have the extension .rbrfw.

3. Select the file and click Open. The file will appear 
on the dropdown list. 

4. Click Proceed to initialise the update. The instrument will disappear from the Navigator window during the 
upgrade. Watch the progress bar at the bottom of the window for the status.  

Do not disconnect the instrument until a confirmation message is displayed. Disconnecting during the update 
process may render the instrument inoperable.
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16 Automatic tasks
When working with a large number of similar instruments, Ruskin offers various automatic tasks.

When using this feature, you will configure your schedule once and then automatically apply the settings to multiple 
instruments.

Access these options from the Instruments menu on the 
top toolbar.

Alternatively, right-click Instruments in the Navigator
window. 

When you enable a task, it will show a checkmark next to it, and the corresponding icon will be displayed in the 
Navigator window. 

Since these tasks can change the state of your instrument, their settings default to "off" each time Ruskin is run.  

When an automatic task is on, Ruskin will execute it as soon as you plug an instrument into your computer. 

Auto-download

When Ruskin detects an instrument, it will automatically start a download process. The downloaded dataset will be 
named following the standard naming convention, and saved in the default directory. Other than possibly creating 
unwanted files, this option is safe since it does not alter the state of the instrument.

Auto-stop

When Ruskin detects a previously enabled instrument, it will automatically stop the deployment.  If auto-download is 
not selected, it will also display a warning about downloading the instrument data. 

All the data on the instrument will be erased as soon as you enable a new deployment.  RBR recommends 
enabling the Auto-download feature whenever you enable Auto-stop. 

https://docs-rbr.atlassian.net/wiki/spaces/RUSKIN/pages/17432802/RSK+files
https://docs-rbr.atlassian.net/wiki/spaces/RUSKIN/pages/17432841/General
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Auto-deploy

When Ruskin detects an instrument, it will stop the deployment and then reprogram your instrument with the last 
known configuration settings. Use this feature when you have several instruments with the same capabilities

To use this feature, follow these steps:

1. Connect to an instrument that will act as the model.

2. Configure this instrument with the desired settings.

3. Enable Auto-deploy as shown above.

Now, when you connect to an instrument with same capabilities as the model instrument, Ruskin will configure it to 
match the the model schedule. 

View auto-deploy settings

To view the currently active auto-deploy parameters, go to Instruments > Automatic tasks > View auto-deploy 
settings... .

The Auto-deploy settings box will open, with saved parameters outlined. 

.

All the data on the instrument will be erased as soon as you enable a new deployment.  RBR recommends 
enabling the Auto-download feature whenever you enable Auto-deploy. 

Auto-deploy implies Auto-stop.
Ruskin must stop your instrument to change deployment parameters, so it will stop even when there is no 
checkmark next to the Auto-stop task. 
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17 Utilities

From the Instruments menu, click Utilities. A dropdown 
menu will open. 

Connect to networked device...

This utility allows a device with serial output to connect to your network via Ethernet. This feature supports remote 
management and monitoring of your instruments from anywhere in the world.

1. Select your network device from the dropdown 
list.
.

2. Specify the IP address and port. 

3. Click Connect.
The Connections tab will display instruments and 
salinometers connected via Ethernet, alongside 
with the instruments physically plugged in to your 
computer. Their IP address and port will appear in 
the Port column. If an attempt to connect was 
unsuccessful, Ruskin will report an error in the 
Status column. 

The Utilities option is a support tool. Contact RBR before using it. 

For the microsalinometer, the port number must be 23.

mailto:support@rbr-global.com
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.To view connected GPS devices, go to the next utility. 

View connected GPS...

This feature allows you to track your instruments during towed deployments. Attach a NMEA GPS to your computer and 
connect to it as described above. Alternatively, connect to one of the boat tracking devices if it has an IP address.

Typically, only one GPS is necessary to track your deployment. Using more than one GPS may bring confusion into your 
data. Click View connected GPS... to see all listening ports. Click the Port button to disconnect. 
.
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18 Revision history

Revision No. Release Date Notes

A 19 February 2026 Initial release
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