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1 Ruskin software

Ruskin is the only tool you need to manage all your RBR instruments and measurement data. It is available for Mac® and

Windows® PC (Ruskin Desktop), as well as for i0OS® and Android™ (Ruskin Mobile).
Use the Ruskin software to do the following:

¢ Configure, schedule, and enable multiple instruments

¢ Estimate your deployment times

* Download your data after logging

¢ View your datasets graphically

e Export your data in various formats

* Analyse your data

* Change the calibration coefficients for your instrument

* Perform user calibration

e Contact RBR

RSK files generated by Ruskin contain raw measurement data, firmware and software versions, dates and times,
sampling settings, power settings, measured and derived parameters, errors and events, other diagnostic information.

They can be read directly in Matlab, or exported to Excel, OceanDataView?®, or text files.

Find Ruskin software for Mac and PC on the USB stick included with your instrument, or visit the RBR website to

download the latest version.

The most recent software updates, release notes, Ruskin user guides, instrument guides, and quick start guides are

available from the Help menu in Ruskin.

‘ Ruskin File Instruments Developer Diagnostic Help

(] ® Ruskin v2.25.0.202512050425 (Customer)
EMLM Release notes
Datasets
: % i s Documentation Sensors
@ Calibration facility J 3 2
5 Compact instruments > Ruskin User Guide: Compact Instruments
Comment on Ruskin... . ;
Standard instruments > RBR Instrument Guide: Compact Instruments
Check for updates... OEM instruments > Quick Start Guide: Compact Instruments
Feature codes... RBRquartz® > Quick Start Guide: RBRduet* T.ODO
RSK processor... Legacy instruments >
i Cables >
Systems >

RBR#0020214revA
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2 Ruskin interface

Ruskin software has a user-friendly interface which consists of a Toolbar and three main windows: Navigator,
Properties, and Plot.

Toolbar

Properties
window

Navigator
window

WA WALNY - NS T T
AL window M

In the Navigator window, you will find the list of instruments connected to Ruskin, as well as MLM and winches (if
applicable), and dataset files.

When an instrument on the list is selected, the Properties window displays three tabs with information related to this
instrument: Deployment, Datasets, and Calibration. Use these tabs to configure your deployment, check the calibration
certificates, and verify your parameters.

The data plot will appear in the Plot window below if the realtime option is available and selected for this instrument,
orif you click the Poll button /¥ on the far right of the toolbar.
Click-and-drag window tabs to rearrange the windows within Ruskin, or move a window outside of Ruskin. Hover over a

side of a window, and when the cursor becomes a two-way arrow  , move it to adjust the window size.

=

Click the Close button in the top right corner to close a window. For example, you can close the Navigator window

5

to have a better view of the Properties. The closed window icon will appear on the sidebar (in this case, Navigator

=
). Click the Multiple windows button above the closed window icon to re-open it.

RBR#0020214revA 6


https://docs-rbr.atlassian.net/wiki/spaces/RUSKINGEN4/pages/692879362/Datasets

5 | simR8Rduet 1.0 900847 _—

Datasets| Calibration

_@' | Clock: ~ 2026-01-2110:42:20 ute Local Sampling
G Now SoC: 100%
[ Battery:  Lithium thionyl chloride e -
@ Pressure c
b simRBRsolo* T 908386 i SMRBRuet* T.D 900847 8 1 PTlA e @ G e B it e S O

Not capturing (backed by [Users/vpeel/900847._20260
Sample #: -~ (101 captured)
Time: -

0 Value st it
1 33601310 °C
2 263903608 dbar
3 - 450565267  dbar
4 346798546  m

s 0

AR

5 a0 0340

FAPFHBAANIDAAN

Double-click a window tab to maximise that window, and double-click the tab again to return it to the original size.

8 &
Alternatively, use the Single window and Multiple windows buttons.

0 When you restart Ruskin, it returns to its original layout.

The Toolbar at the top left above the Navigator window has four dropdown menus. If you are using a Mac computer, it
appears as follows:

@ Ruskin File Instruments Help

On a Windows PC, the Toolbar looks slightly differently:

File Instruments Options Help

The rest of the interface is the same between the two systems.

2.1 File

Go to the File dropdown menu to open or close a dataset, export your data, and see the list of available datasets. The
Datasets menu in the Navigator windows duplicates some of these options for convenience.

@ Ruskin File Instruments Help
( } ® Open dataset
4 Navigator

v @ Instrumen Export >
® simRBRsol
OsimRBRdur 1 908190_20251218_1448 _realtime.rsk

win MLM 2: 907951_20251209_1437_realtime.rsk

' Datasets  3: 901814_20250616_1638_realtime.rsk
@ (Calihratinr

RBR#0020214revA



2.2 Instruments

Go to the Instruments dropdown menu to Simulate an instrument, Update firmware, set up Automatic tasks, or access
the Utilities.

0 Automatic tasks and Utilities are not applicable for sensors.

A The utilities option is a support tool. Contact RBR before using it.
® Ruskin File

45 Navigator

Instruments  Help

Simulate...

Disconnect

= Update firmware... =
v @ Instruments

@ simRBRsolo* Automatic tasks > I
O simRBRduraturo*
wim MLM Utilities >

' Datasets

You can also access the Simulate... and Automatic tasks options by selecting the Instruments context menu in the
Navigator window.

2.3 Help

@& Ruskin File Instruments = Help

Go to the Help dropdown menu to access the latest

X eoe
Release notes and Documentation, Comment on ——
Ruskin..., Check for updates..., as well as access Feature - @ Instruments | i
. ® simRBRsolo* 901979 i
codes. On Mac, you can also use the Search option. OsimRBRduraturot 904551 o
=I")ALtM ; Check for updates...
atasets

r Feature codes...
@ Calibration facility s

2.4 Ruskin /Options

& Ruskin File

[ M} About Ruskin

Settings...

On your Mac, go to the Ruskin dropdown menu to access
information on your current software version, edit your
Settings, or Quit Ruskin. Note that the rest of the options
on this dropdown menu depend on your operating
system and are external to Ruskin.

Instruments  Help

B

Services > _
Hide Ruskin g
Hide Others

Show All

IPOH

o

Quit Ruskin

On your Windows PC, edit you Settings using Options >
Preferences.

RBR#0020214revA
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3 Installation

Ruskin is the only piece of software you need to operate your RBR instruments. RBR releases Ruskin software versions
compatible with Mac and PC (Ruskin Desktop), as well as with iOS® and Android™ (Ruskin Mobile).

Install the Ruskin Mobile app on your mobile device by going to the Apple App store or Google Play.

Follow the steps below to install Ruskin Desktop on your computer.

3.1 Install Ruskin on PC

You can install Ruskin on a PC that runs the Windows 7, 8, 10, or 11 operating system.
The minimum requirements for Ruskin are:
® OS=Windows 7
® Processor speed = 1.4GHz
® RAM required = 8GB
¢ Display resolution =1024x768
© 1920x1080 (recommended)

HDD space for installation = 2GB

The instruments use either a USB interface or an RS-232 serial port to communication with Ruskin.

Steps

Realtime sensors will not require USB drivers to operate, they are only required for our standard and compact
instruments.

1. Connect the USB stick included with your instrument to a port on your computer.

2. Navigate to the Ruskin Installation folder and double click on the on the file RuskinSetup.exe .

3. Follow the installation wizard. By default, Ruskin will be installed to C: \RBR

4. At the end of the installation, you will see a prompt asking, “Would you like to install the logger driver at this
time?”
5. Click Yes to install the drivers

You may need to run the setup application as an administrator to install the driver correctly.

A shortcut to Ruskin will appear on the desktop and in a Start menu folder.

o The most recent version of Ruskin software can be found at https://rbr-global.com/products/software.

3.2 Install Ruskin on Mac

You can install Ruskin on a Mac running OS X 10.12 (Sierra) or later.

Always use the default Applications folder as the working directory.

RBR#0020214revA
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Steps

1. Connect the USB stick included with your instrument to a port on your adaptor.

2. Navigate to the "OSX" folder and double-click on the file Ruskin.dmg .

3. When the disk image window opens, drag the Ruskin icon into the Applications directory and wait for the copy

to complete. An application named "Ruskin" will appear in the Applications folder.
4. Right-click on the icon, and select Open.

5. The dialogue box shown below will prompt you to authorise the opening of Ruskin.

“Ruskin” Not Opened

Apple could not verify “Ruskin” is
free of malware that may harm your
Mac or compromise your privacy.

Move to Trash

Done

You may need to navigate to System Settings... > Privacy & Security > Allow applications from and select
App Store & Known Developers to complete the installation.

3.3 Update Ruskin

To take advantage of new features and bug fixes, ensure that you are using the most recent version of Ruskin.
¢ Find the most recent version of Ruskin at https://rbr-global.com/products/software.
® Receive an automatic notification about a new release when you start the application.
e Check from within Ruskin by navigating to Help > Check for updates....

® Send an email to support@rbr-global.com, subject: "Ruskin update request", and ask us to add you to the
mailing list. You will receive an email as soon as the new version is released.

If you have a broadband connection, simply follow the installation instructions on your computer. Otherwise, request a

USB stick from RBR.

It is not necessary to uninstall the older version of Ruskin before installing the newer version. The installation
program deletes the older files before installing the newer ones. It does not delete any Ruskin data files or log
files.

RBR#0020214revA
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3.4 Uninstall Ruskin

Uninstall Ruskin only if you no longer need to manage RBR instruments from your computer.

It is not necessary to uninstall the older version of Ruskin before installing the newer version. The installation program
deletes the older files before installing the newer ones. For more information, see Update Ruskin.

Removing Ruskin will not delete your data files or your diagnostic logs, provided they have not been saved to
the Ruskin installation folder.
Uninstall Ruskin on a PC, Windows 7, 8, 8.1,10, or 11

1. Go to Start > Control Panel > Programs.

2. Under Programs and Features, click Uninstall a program.

3. Find Ruskin on the list.

4. Click Ruskin to highlight it.

5. Click Uninstall.

Uninstall Ruskin on a Mac, OS X 10.12 or later

Move the Ruskin application from Applications to the Trash.

RBR#0020214revA 11



4 Support

When experiencing an issue, look for a solution under the Help menu before contacting RBR.

You can get in touch with RBR in several different ways:

e Send us an email. Fortechnical questions, use support@rbr-global.com, and for general inquiries, info@rbr-
global.com.

® Contact us via the website at https://rbr-global.com/contact-us/.
e Callusat+1(613) 599-8900.

¢ Send us a bug report from within Ruskin itself Help > Comment on Ruskin

The Help menu in Ruskin offers access to technical documentation, feedback forms, and software updates. On Mac,
you can also search for Ruskin menu options.

4.1 Release notes

Go to Help > Release notes to open the Welcome window. It will outline new features, improvements, and bug fixes
associated with each release version.

Select Click here to see all Release notes to see the full history of the release notes. The link will take you to the RBR
support page. Alternatively, scroll down to see brief recaps of the release notes from all previous versions.

To exit and return to the Navigator mode select x on the Release notes tab

4.2 Documentation

Select Help > Documentation to access an instruments Quick Start Guide, Instrument Guide, and Command reference.

| Ruskin v2.25.0.202512050425 (Customer)

Release notes 1
Documentation > Sensors >

Compact instruments >

Comment on Ruskin... mfﬁ

truments Ruskin User Guide: Standard Instruments
Check for updates... OEM instruments > Command Reference: Standard Instruments
Feature codes... RBRquartz?® > RBR Instrument Guide: Standard Instruments
RSK processor... Legacy instruments > RBR Instrument Guide: C.T/C.T.D Instruments
i Cables > RBR Instrument Guide: C.T/C.T.D |uv Instruments
Systems > Quick Start Guide: Standard Instruments

Quick Start Guide: C.T/C.T.D |uv Instruments
Quick Start Guide: Ruskin Mobile

Documentation can also be found on the RBR website.

RBR#0020214revA 12
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4.3 Comment on Ruskin

Sending a bug report from within Ruskin allows you to include the diagnostic logs, RSK datasets, screenshots, and any
other files that could help us reproduce the problem and find the solution as quickly as possible.

To submit a bug report:
1. Click on Help > Comment on Ruskin... . The Feedback to RBR form will appear.
2. Enter your Name and Email address.
3. Enter a brief Summary of the problem.

4. Provide a detailed Description (serial number for the instrument, overview of the problem, deployment details,
initial tests, and, for software bugs, steps to reproduce the issue)

5. Include any attachments, if required.

6. Verify all the information entered and select Submit.

4.4 Check for updates

To search for the latest software version, go to Help > Check for updates.
If your software is up-to-date, no further action will be required.

If an update is found, Ruskin will offer to install it. Follow the prompts then restart Ruskin for the updates to take effect.

4.5 Feature codes

Sometimes, RBR may release new features to certain users only, as a beta trial. This includes:
® Featuresin early development
e Features supporting a new product, in preparation for the product launch

¢ Features requested by a specific customer

Usually, the goal is to get feedback and improve the feature before its official release. Contact your sales representative
or RBR support team at support@rbr-global.com if you have questions about your feature code.

To access a new feature:
1. Click on Help > Feature codes..., to access the Feature codes window.
2. Enter the feature code provided by RBR.
3. Click ADD.

If the code is correct, Ruskin will save the feature in the local database and enable it. In most cases, you will have access
to the new feature immediately, without restarting Ruskin. If addition instructions are required, you will receive them
along with the feature code.

Errors
¢ The feature code is not valid.

o This error may indicate the code was entered incorrectly or it is not compatible with the current version
of Ruskin.

¢ The feature code is already enabled.

© This error may occur when another user has already activated this code.

RBR#0020214revA 13
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5 Quick start - Ruskin Desktop

Ruskin Desktop version is designed for computers and laptops. It generates dataset files which include raw
measurement data, firmware and software versions, dates and times, sampling settings, power settings, measured and
derived parameters, errors and events, calibration coefficients, and diagnostic information, offering the fullest Ruskin
experience.

5.1 Simulate an instrument

Ruskin can simulate most instruments and sensors that RBR produces. We recommend that you experiment with
different simulated options before enabling a schedule for your actual deployment. This practice will also help you
become more familiar with how an RBR instrument interacts with Ruskin and how to configure its settings and
features. Work with simulated instruments the same way as you work with a real RBR instrument, configuring,
calibrating, and fetching data.

Currently, you cannot enable simulated instruments or download their data. For more information, see Deploy
your instrument.

Steps

1. From the Instruments menu, click Simulate... @ Ruskin File Instruments  Help

@] @ Simulate...
Disconnect

i+ Navigator
— Update firmware... E
V. i Instruments

OsimRBRsolo* Automatic tasks >
O simRBRduraturo®

OsimRBRsolo* Utilities >
mn MLM

Gend Gen3 Legacy Systems

Compact instruments  Standard instruments  Sensors 135  ASN

The Configure simulated instrument dialog box
will appear.

= F
Ifast16
RBRduraturo® T.D  temperature - pressure Ifast32

2. Click your instrument family and make your
selections.

3. Click OK to proceed.

0 Depending on the instrument selected, the Options dropdown menu may contain | fast sampling rates, | tide
and | wave variants, tilt, or no options at all (in that case, the menu will be greyed out).

4. Your instrument will appear under Instruments in s+ Navigator
th.e Navigator W|.nd0\./vn. §|mulated |ns'Fruments v @ Instruments
will have the prefix “sim” in front of their name. © simRBRsolo® 905072
© simRBRduraturo® 904133
O simRBRsolo* 901408
wan MLM
. Datasets

RBR#0020214revA 14



The instrument properties will be displayed on the right, under three tabs:

* Deployment - displays status, clock, sampling mode and speed, power options, and deployment estimates
based on these parameters.

¢ Datasets - displays the datasets contained in the instrument. Provides functionality to download and delete
individual datasets.

e Calibration - allows access to the current calibrations for each channel in the instrument.

Familiarise yourself with the instrument by changing configuration options and comparing deployment estimates.
Select the desired configuration using the dropdown options or entering the values manually in the fields provided.

For simulated instruments, the Plot window will remain empty unless you click the Poll button i3

Manage multiple instruments by switching between them in the Navigator window.

° To remove a simulated instrument from Ruskin, right-click the instrument name in the Navigator window, and
select Disconnect. You can also use the Instruments menu.

Alternatively, simply close its Plot tab by clicking the X. The instrument will disappear from the list.

5.2 Deploy your instrument

Before using your RBR instruments, you may want to experiment with different options by simulating your instrument
on Ruskin.

When you are ready to use your physical RBR instrument, follow the steps below to ensure that you measure exactly
what you want on the first attempt.
Steps

* Locate a USB-C port inside of the instrument. See the section on opening and closing your instrument in the
relevant Instrument Guide for more details. Guides are available on Ruskin under Help > Documentation.

® Plug one end of the USB cable (USB-C to USB-C, provided with your instrument) into this port and the other, in
the USB port on your computer.
The instrument will appear in the Navigator view after a few seconds. The properties for the instrument will be
displayed in the Properties window, grouped under three tabs: Deployment, Datasets, and Calibration.

¢ If you are using the instrument for the first time, you can use either the default preferences or specify your own.
For more information, see Settings > General. You can change them at any time.

¢ Click the instrument you want to use. Verify that it contains the expected sensors under the Calibration tab.
e Click the Calibration tab to view or modify calibration coefficients.

¢ Click the Deployment tab and go to the Scheduling cards section to select the mode and speed of
measurements.

° Ruskin will allow a deployment to run until the instrument can no longer sample. This could be due to a full
memory or due to power supplies being exhausted. It will display the estimated battery usage and storage
capacity based on the parameters you enter. The green widget next to End will indicate the number of days
your instrument would be sampling, along with the icon representing the limiting factor, battery or memory.
Carefully consider this information before you enable a deployment schedule. For more information, see
Schedule.

¢ Click the Enable button at the bottom of the Deployment tab to take samples according to the schedule that
you specified.

RBR#0020214revA 15
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Your deployment will continue until the battery runs out, the memory is full, or you stop your schedule
manually.

* When your deployment stops, click the Download latest button at the bottom of the Deployment tab to
transfer all the sampled data from the instrument to your computer. For more information, see Download latest.
As soon as you download a new dataset, it will appear in the Navigator window. Refer to Dataset files for details
on managing and analysing your data.

° If you want your data streamed or fetched, specify these preferences before you enable the schedule:
1. To see live data sampled every few seconds, click the Poll button
1"

on the far right of the toolbar above the Plot view, without enabling the schedule.

2. To start streaming, click Enable. The data will immediately appear in the Plot window below.
The instrument does not store streamed or fetched samples, but Ruskin will record them in the
realtime RSK file.

° To restore a closed connection to an instrument on Ruskin, click Instruments in the Navigator window. A list
of all instruments physically connected to your computer will appear in the Properties window.

Find your instrument and deselect its checkbox, and then select it again.
Your instrument will re-appear in the Navigator window.

5.3 Recover your instrument and download data

When deployment is complete, recover your instrument and follow these steps to download your data.

0 Flooded instruments may be under pressure and opening them may be dangerous. Take precautions when
opening an instrument after deployment.

Steps
1. Start Ruskin.

2. Carefully remove the battery end-cap. See "Opening and closing the instrument" section in the corresponding
RBR Instrument Guides for more details. The Guides are available on Ruskin under Help > Documentation.

3. Locate a USB-C port inside of the instrument.

4. Plug one end of the USB cable (USB-C to USB-C, provided with your instrument) into this port and the other, in
the USB port on your computer.

5. The instrument will appear in the Navigator view after a few seconds.
6. Under the Datasets tab, click Download. See Download latest for details.

7. The file is automatically downloaded to the location specified in Settings > General. See General on steps to set
up your default location.

8. Evaluate your data. See Analysis for details.

Disconnect from your instrument

To disconnect an instrument from Ruskin, right-click it in the Navigator window, and select Disconnect. You can also
use the Instruments menu.

Alternatively, simply close its Plot tab by clicking the X. The instrument will disappear from the list. Please note that
you will be able to reconnect to it at any time because Ruskin remembers the port of a plugged instrument.

RBR#0020214revA 16



Reconnect to your instrument

To restore a closed connection to an instrument on Ruskin, click Instruments in the Navigator window. A list of all
instruments physically connected to your computer will appear in the Properties window, under the Connections tab.

Find your instrument and deselect its checkbox, then reselect it again. Your instrument will re-appear in the Navigator

window.

- Navigator ~ O || 2 connections %
O simRBRsolo* 905072
OsimRBRsolo* 901408 Port Status RF latency (s) Device
OsimRBRduraturo* 904538 simRBRsolo* x Connected to simRBRsolo* x 0 Logger
s MLM simRBRduraturo® T Connected to simRBRduraturo* T 0 Logger
v & Datasets simRBRsolo* T Connected to simRBRsolo* T 0 Logger

010 908190....rsk

Remove your instrument
To completely remove your instrument from Ruskin, unplug it from your computer.

Alternatively, deselect the checkbox next to your instrument, and Ruskin will disable transport to its port.

If you uncheck this port, Ruskin will never detect the instrument again on that port. To use this port for an
instrument, the port must be checked/enabled.

4F Navigator = B || 2 connections &%

i Instruments

win MLM
g Datasets Port Status RF latency (s) Device
o 203672...1240 /dev/tty.usbmodem1412101 Transport disabled 0 Logger

o1 209718...time
o 209718...1210
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6 Connections

Use the Connections tab to view and manage devices connected to your computer via physical ports or Ethernet.

In the Navigator window, click Instruments. The Connections tab will open on the right. The table will include ports,
statuses, RF latency selections, and the device type for each connected device.

" Connections 23

Port Status RF latency (s) Device
v /dev/tty.usbmodem13201 Connected to RBRduraturo® T.D|wave32 0 Logger
v /dev/tty.usbserial-0 Connected to RBRcoda® T.D|fast32 0 i Logger
1
2
3
4
Column Information
Port If your instrument is plugged in to your computer, this column will identify the physical port by

name, such as "COM5" (if using Windows) or by its address, such as "/dev/
tty.usbmodem141101" (if using MAC OS).

Status The column will display a success message, such as "Connected to RBRconcerto® 209681", or
an error message, such as "Unable to connect to host".

RF latency (s) From the dropdown menu, select a value up to 29 seconds. The selected value will extend the
allowable time for an instrument to respond to a command. Use this option when on a long
cable or slow Wi-Fi connections.

Device The column will display the device type for each connected device:

¢ Logger: Instruments connected via USB, serial (RS-232), or TCP connections
® RS-485: Instruments connected via serial (RS-485) connections

¢ GPS: NMEA streaming devices

See Deploy your instrument on how to locate the USB-C port on your instrument and connect it to your computer.

As soon as you plug in an instrument, Ruskin will detect it and add it to the list.

= Navigator = O || = connections 2
ORBRsolo* 2414
wim MLM Port Status RF latency (s) Device
& Datasets /dev/tty.usbmodem1201 Connected to RBRsolo* T.ODO|slow 0 Logger
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Click on one of the instruments to switch to its Deployment tab.

1 Navigator = O | £ ReRsolo* 907983 52
v @ Instruments ‘ Dep 1t _Datasets | Cali
ORBRsolo* 907983 -
MM
£ Datasets -
® Cali 9 il Status: | Not enabled Firmware: 1.0.0 Temperature Continuous - 2Hz
@ Calibration facility [ ] Links USB
Clock:  2026-01-12 14:56:38 utC Local Power:  USB Sampling

Internal: ~ 3.60V

Start:  2026-01-12 ¥ 2:00:00PM & Now Mode: ~ Continuous g

End: Gated Period: v Rate 2Hz <

Battery:  Lithium thionyl chloride o3

Calibration deployment

Discover sensors

Schedule is valid

If you unplug an instrument, the port will remain enabled as long as the port checkbox remains selected. Ruskin will
automatically reconnect to the instrument when it is plugged back in.

Deselect the checkbox next to your instrument to disable transport to its port. After this, Ruskin will not detect any
instrument plugged into this port.

= -
45 Navigator 8 H [ Connections £ .
@ Instruments A
i MLM -
a Datasets Port Status RF latency (s) Device
@  /dev/tty.usbmodem1201 Transport disabled 0 Logger

To restore transport, reselect the checkbox. Your instrument will re-appear in the Navigator window.
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7 Deployment

Use the Deployment tab to set up your deployment parameters.

| RBRduraturo® T.D|fast16 241215 5%

Deployment . Datasets | Calibration

Status: (Instrumentdisabled ] Firmware: 1.0.0 ‘ Temperature Continuous + 16Hz ’
Link: usB

Clock: 2026-02-11 09:34:07 uTC Local Power: usBe

: e Internal:  0.00V Pressure Continuous - 16Hz ’

. Twist activation & v ‘
st SoC: 100%
o W

Battery:  Lithium thionyl chloride ©
Enable

After setting up a desired schedule, click Enable. New values will replace all previously stored deployment and
schedule parameters.

° The instrument must be disabled to change a setting. A new deployment must be enabled for the new settings
to take effect.

You can also use the Deployment tab to view general information for each of your instruments, such as serial number,
firmware version, power type (internal or external), and voltage.

The SoC (State of Charge) value indicated for the internal source indicates the power remaining in your batteries.

o Itis not a good idea to use voltage as a health indicator of the battery as the voltage drop in certain
chemistries can be very sharp.

7.1 Update firmware

Ruskin automatically checks if your instrument firmware is up-to-date. Updates may be critical, routine, or customised.

If a newer version is available and this update is critical, the Update firmware button and a warning message will
appear at the top of the Deployment tab.

Update

See Critical firmware updates for details.
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7.2 Schedule

The Schedule section includes four fields: Status, Clock,

Start, and End. Status: (Not enabled ]
The Status field displays the current state of your el SRR TS uTC Local
instrument.
Start: v Now
End:  2026-07-23 ([ 165 days ] Eo
Battery:  Lithium thionyl chloride &
Energy per second: 2.26 mJ
Calibration deployment
Status Description
Not enabled A deployment has not been enabled.

Configuring instrument
Schedule enabled
Paused

Logging in progress

Logging, memory full

Stopped, schedule complete

Stopped, memory full

Stopped, user request
Failed

Battery failed

RBR#0020214revA

Ruskin is writing the deployment configuration to the instrument.
A deployment has been enabled, but the start time has not yet been reached.
A deployment has been enabled, but a gating condition has not been met.

A deployment has been enabled and the instrument is currently obtaining
samples and recording them to memory.

A deployment has been enabled and the instrument is currently obtaining
samples, but they are not being recorded to memory as there is no available
space. Data continues to be transmitted over the chosen realtime link.

A deployment has reached the end time and so has been stopped.

The memory has been completely filled with samples and so logging has been
stopped.

An enabled deployment has been stoped by user intervention.
An internal error has occurred during a deployment.

An internal error with regarding the batteries has occurred.
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Clock

The instrument clock may drift up to 60s per year. Hover Deployment _Datasets | Calibration
your mouse over the time value to display the offset.
Status: (Not enabled ]
Clock: 2026-02-17 10:57:52 uTC Local
Start: Twist acti Logger time matches computer time
[H 10.0+ years ] B eo]
Battery:  Lithium thionyl chloride

Energy per second: 2.66 mJ

Calibration deployment

Synchronise the instrument clock before each deployment. Select UTC or Local time, depending on your preferences.
Start

The Start date and time are only editable If the Start condition is set to Scheduled. Otherwise, it is the Start
condition selection that will control the start of logging. See Gating for details.

End

The End date is calculated by Ruskin autonomy engine and indicates when your deployment is likely to stop. This is
based on sampling schedule, mode, and power selections . Ruskin autonomy engine provides feedback on which
parameter (power or memory) will be exhausted first.

End:  2026-07-10 [E 155 days ] ioo]

The parameter in the green bar is the true deployment estimate. In the example shown, your deployment will last 155
days, until the battery is exhausted.

Ruskin uses power tracking data stored in the instrument to adjust its autonomy calculation to account for
power already used from previous deployments. If new batteries are inserted in the instrument, check the
‘fresh’ check box next to the battery selection. This will indicate that the autonomy calculation should assume
fresh batteries for the deployment.

The parameter in the orange bar indicates that your instrument could last longer than the number of days indicated in
the green if the preceding parameter were not a factor.

° If the End logging date is power dependent and if you know that the instrument will be operating under very
cold conditions, you may want to lower the demands on the battery by lengthening your sampling period or
opting for different battery chemistry.

Ruskin autonomy engine

Ruskin autonomy engine relies on several parameters to estimate the deployment end date: sampling rate, power
options, and memory. One of the key factors is battery life.

Battery life prediction is a complicated issue. In RBR instruments, it is a strong function of the type of instrument, type
and number of sensors attached, sampling mode (sampling rate, gating conditions, realtime data collection), and water
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temperature during the deployment. Manufacturer data for the batteries may not reflect the way batteries are used in
RBR instruments, and thus, are not always informative.

Autonomy figures depend on the power draw of the instrument, as well as the derated capacity of the battery pack.
Batteries are derated to 4°C. These values differ for different battery chemistries. For the most accurate deployment
estimates, select the same batteries from the dropdown menu as installed in your instrument.

Ruskin calculates the expected battery usage for the instrument during setup . The nominal capacity of each type of
battery is described in the Power section and is given in mAh at room temperature. Battery voltage does not decrease
linearly and is therefore not an accurate indicator of battery capacity.

RBR tested batteries of various brands at 6°C; all of them were able to provide the threshold capacity defined in the
Power section. View these predictions and further de-rate the batteries if the expected deployment is in cold water.

The software will warn you if the expected battery usage for a particular deployment scenario is approaching the
theoretical potential mAh.

(€] Warning
There is insufficient power for the deployment

Would you like to proceed?

The software will not prevent your instrument from being started even if a warning is given. However, adjusting
deployment parameters or replacing the batteries may help extend deployment times.

7.3 Power

The Rower section |nc.ludes battery chemistry options. S e [Q 99.0 days ] E w}
Ruskin autonomy engine uses these parameters to

estimate deployment life. Battery:  Lithium thionyl chloride e

The Battery dropdown menu shows available chemistry
options for internal batteries. The list depends on your
instrument.

Energy per second: 3.52 mJ

RBR ships all new instruments with batteries of the highest capacity for the instrument type already installed.

o Mixing batteries of different chemistries, brands, and age will reduce performance and potentially damage the
instrument. Improperly matched batteries may become overheated, leak, or even explode.

Typically, RBR instruments are shipped with EVE ER14505 lithium thionyl chloride or Energizer L91AA lithium iron.
Select your battery chemistry from the dropdown list.

Name Chemistry Voltage (V) >
Lithium thionyl chloride Li-SOCL 5 3.6 209,950
Alkaline Zn-Mn0O, 1.5 64,800J
Nickel metal hydride Ni-MH 1.2 36,720
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"The nominal capacity of each type of battery is given at room temperature.
Deployment estimates

Ruskin estimates autonomy figures based on the power draw of the instrument, as well as the derated capacity of the
batteries. Batteries are derated to 4°C . These values differ for different chemistries (see above). For the most accurate
deployment estimates, select the same batteries from the dropdown menu as installed in your instrument.
Alternatively, use Ruskin to simulate your instrument with different batteries and find which chemistry works best for
your deployment.

Battery cells of the same chemistry but from different manufacturers may have different performance. If the
nominal capacity of the battery model you are using is lower than outlined above, your actual deployment
may be shorter than the estimate.

° Replace batteries before each deployment to maximise the operational time and prevent data loss.

Select the Fresh checkbox when installing fresh batteries in your instrument for the next deployment. When checked,
Ruskin autonomy engine will reset usage statistics and adjust deployment estimates accordingly.

7.4 Gating

Gating allows you to enable your deployment using a method other than time-based. From the dropdown menu next to
Start, select Now to start your deployment straight away, Time to Schedule your deployment at the date and time
selected in the fields to the right, or Twist activation to start your deployment by twisting the end-cap.

Clock: 2026-01-19 10:09:11 uTc Local
start: v/ Now 3 v

Time -
End: Twist activation gars Ho
Battery:  Lithium thionyl chloride (2]

Twist activation

When you select Twist activation, the instrument starts to sample based on the twist on/off position of its end-cap
rather than a schedule.

To start sampling, first click Enable. This button is at the

bottom Of the Deployment tab. Status: [Instrumem disabled ]
Clock:  2026-01-26 15:64:53 uTC Local
Start: Twist activation & v
End: Gated [i 677 days -
Battery:  Lithium thionyl chloride (2]
Enable Download latest
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The button will then become a Stop button. The status
will become "Deployment paused". sraus: (Y )

Clock:  2026-02-20 14:05:11

Start: V.

Battery:

Stop Resume Download latest

Turn the battery end-cap to the RUN position.
The instrument will vibrate with one long pulse and start
sampling.

To pause it, turn the battery end-cap to the PAUSE
position. The instrument will vibrate with three short
pulses to indicate it has stopped logging.

A Twisting the end-cap to the RUN or PAUSE position will activate the Wi-Fi. However, twisting to PAUSE will
also pause the instrument. Twisting to RUN will resume sampling.

7.5 Scheduling cards

The Scheduling cards represent the sensors on the instrument, so each sensor will have a separate card allowing each
sensor to be scheduled independently.
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Each card includes a Mode field, as well as several

optional fields available with certain sampling modes. If Temperstre Contnuons e
the fields are not visible click anywhere on the card to sampling
expand |t Mode: Continuous e

Period: Rate 2Hz (<]
To schedule a sensor ensure the checkbox next to the

sensor name is selected.

Pressure Continuous + 2Hz
Sampling
Mode: Continuous (C]

period: @ Rate 2Hz @

When connecting an RBRsolo? x or RBRduet? D.x, Ruskin select Discover sensors to request Ruskin to search for the
correct sensor.

Mode

Depending on your instrument, different dropdown options may be available. See Average, Burst, Directional, Tide,
and Wave for information on how to configure these modes.

Speed and Rate
These are the only two parameters you need to configure Continuous sampling mode.

Check Period to select the sampling Rate in Hz from the dropdown menu. The default option is always the highest
instrument rating. For example, | fast32 will default to 32Hz.

o All profiling instruments (known as | fast) can sample faster than 2Hz and support Average and Burst modes.
All | tide and | wave instruments can average at rates of 2, 4, 8, 16 or 32Hz.

Uncheck Period to enter the sampling Rate manually in hours, minutes, and seconds (HH:mm:ss format). The fastest
rate to enter manually is 1s. Type the numbers in, or use the up and down arrows.

7.5.1 Average

When set to Average, the instrument will collect data at a certain rate, and then average those samples to produce a
single value to store on the instrument. This sampling mode allows you to save memory during long deployments.

In addition to Rate, there are two more parameters required for Average mode: Measurement duration and Period.

Measurement duration specifies the time range over which to average. It must always be longer than Rate.

Period is the repetition period for performing the averaging. It must always be longer than Measurement duration.

Sampling controls

When using the advanced version, select two or all three Eamping

parameters manually. Mode: Average 2]

In the example shown, the sampling rate selected is 2Hz Measurement period: @ Rate  2Hz @
(two samples per second). The instrument will be logging Messurement durstion: QUL S

. . Period: :05:
for a duration of one minute, then pause and average the ks 20900 |

120 samples collected. After an interval of five minutes, it
will start logging again, repeating the same cycle.
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In the second example, the sampling rate selected is 1s Saping
(1Hz, or one sample per second). Measurement Mode: Average 3
duration and Period are the same in both examples.

Measurement period: Rate 00:00:01
Measurement duration: 00:01:00 <
Period: 00:05:00

o At every Period, the instrument records only one sample, averaged over all samples collected during the
period of Measurement duration. The rest of the samples are discarded after averaging is performed.

7.5.2 Burst

When set to Burst, the instrument will collect a specified number of samples at a specified rate, and repeat this
operation at a specified interval.

o Only instruments with the | fast sampling feature support Burst sampling mode.

In addition to Rate, there are two more parameters required for Burst mode: Measurement count and Period.
Measurement count specifies the number of samples to record.

Period is the repetition period for performing the burst. The countdown begins at the same moment the burst starts
and, therefore, Period must always be longer than the time it takes to obtain the number of samples indicated in
Measurement count.

Sampling controls

Select Rate, Measurement count, and Period from pre- Sampling

defined options in three dropdown menus. Mode: Burst 8

In the example shown, the sampling rate selected is 2Hz Measurement period: @ Rate 2Hz @
(two samples per second). The instrument will be logging Measurement count: 512 S
for a duration of 512 samples (256 seconds), then pause Period: [00:05:00 | <

for 44 seconds (that is, until the countdown reaches 300s
or five minutes). After an interval of five minutes, a new
burst of 512 samples will occur, the instrument repeating
the same cycle.

7.5.3 Tide

Tide sampling mode collects data at a certain rate, and then averages those samples to produce a single value to store
on the instrument. When set to Tide, the instrument uses averaging to remove wave noise data from pressure
measurements.

0 Allinstruments with the | tide32 and | wave32 features support Tide sampling mode.

In addition to Rate, there are two more parameters required for Tide mode: Measurement duration and Period.
Measurement duration specifies the time range over which to average. It must always be longer than Rate.

Period is the repetition period for performing the averaging. It must always be longer than Measurement duration.
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Sampling controls

Select Rate from pre-defined options in the dropdown SR

menu. Then manually enter the Measurement duration Mode: Tide (2]

and Period Measurement period: Rate 32Hz [
Measurement duration: 00:01:00 S
Period: 00:05:00 |

In the example shown, the sampling rate selected is 32Hz (32 samples per second). The instrument will be logging for a
duration of one second, then pause and average the sixteen samples collected. After an interval of five minutes, it will
start logging again, repeating the same cycle.

0 At every Period, the instrument records only one sample, averaged over all samples collected during the
period of Measurement duration. The rest of the samples are discarded after averaging is performed.

7.5.4 Wave

Wave sampling mode collects a specified number of samples at a specified rate, and repeats this operation at a
specified interval. When in Wave mode, the instrument takes multiple pressure readings in a burst and reconstructs the
surface wave time series. This mode records both tide and wave information.

0 Only instruments with the | wave32 feature support Wave sampling mode.

Measurement period or Rate are parameters defining individual pressure readings.

* The highest possible frequency visible in the data is limited to 72 the sampling rate. However, this mathematical
limit cannot be achieved because of wave attenuation, and real data are actually lower.

® The sampling rate defines the resolution of the frequency spectrum which can be calculated from the wave
data.

® The sampling rate, together with the burst duration, defines the lowest frequency which can be assessed in a
wave burst.

In addition to Measurement period and Rate, there are two more parameters required for Wave mode: Measurement
Duration and Period.

Measurement duration specifies the number of samples to record.

Period is the repetition period for performing the burst. It must always be longer than the time it takes to obtain
the number of samples indicated in Measurement duration.

Consider unique aspects of deployment environment when setting up Wave sampling mode.

For example, while a 30-minute interval tends to work in most cases, shorter intervals may suit better when
encountering ocean swells which have longer wavelengths than noise but shorter than tide.

Furthermore, you may enter Instrument altitude and Mean depth of water to estimate possible wave periods for your
deployment. These parameters are not mandatory for the instrument to work, but allow you to get an idea of what to
expect.

¢ Instrument altitude is the actual height of the instrument in metres above the seabed. This is defined by
deployment requirements, and the instrument must be physically affixed at this height during the installation.

o This parameter is stored on the instrument and used to compute wave statistics for pre-deployment
analysis.
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¢ Mean depth of water is an estimate of the average water depth in metres, used for the initial prediction of wave
frequency. It must always be greater than Instrument altitude.

© This parameter is not stored in the logger and only used to compute wave statistics. It is adjusted post-
deployment through the RSK file.

o Ruskin will calculate the actual mean depth of water from the instrument altitude and its depth
measured during the deployment.

Sampling controls

Select Rate and Measurement count from the drop-down menus, and enter Period manually. For example, with a rate
of 4Hz and a duration of 4096 samples, the instrument will be sampling 17 minutes 4 seconds. You can set up near
continuous sampling by setting the interval to 17:05. Logging will be on every second except the one remaining second

of the interval, and then start again.

Sampling

Hz
2Hz
Measurement period: Rate v/ 4Hz
8Hz
16Hz
32Hz

Mode: = Wave a

Measurement count:

Period:
Wave bandwidth
Instrument altitude (m): 1.0
Mean depth of water (m): 10.0

Maximum wave frequency: 0.2252 Hz
Minimum wave period: 444 s

Pressure Wave - 4Hz + 4096 - 00:30:00

LR

Enter Instrument altitude and Mean depth of water
manually. Estimates for wave statistics will be
immediately displayed: maximum wave frequency and
minimum wave period (essentially, they reflect the same
concept because period = 1/frequency). These values can
be adjusted post-deployment through the RSK file.

Pressure Wave « 4Hz - 4096 - 00:30:00 Pressure Wave « 4Hz - 4096 - 00:17:05
Sampling Sampling
Mode: Wave e Mode: Wave ©
1024
Measurement period: Rate 2048 ! Measurement period: Rate  4Hz 2]
Measurement count: ) Measurement count: 4096 e
Period: 8192 & Period: 00:17:06 | <
Wave bandwidth 16384 Wave bandwidth
32768
Instrument altitude (m):  1.L Instrument altitude (m): 1.0
Mean depth of water (m): 10.0 Mean depth of water (m): 10.0
Maximum wave frequency: 0.2252 Hz Maximum wave frequency: 0.2252 Hz
Minimum wave period: 444 s Minimum wave period: 444 s
Pressure Wave - 4Hz - 4096 - 00:17:05
Sampling
Mode: Wave e
Measurement period: Rate 4Hz &
Measurement count: 4096 a
. [ ~
Period: 00:17:05 v

Wave bandwidth

Instrument altitude (m): 1.0
Mean depth of water (m): | 10.0

Maximum wave frequency: 0.2252 Hz
Minimum wave period: 444 s

° The timestamp of the burst for both Tide and Wave datasets is the beginning of the burst.

Deployment depth of | wave32 instruments

° The basic rule is to place the instrument as close to the surface as possible without it emerging from the water

due to large waves or low tides.

Attach your | wave32 instrument to a suitable support below the surface of the water, such as a dock or other rigid

mooring, to completely immobilise it.
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Enter the expected mean depth of water and the known instrument altitude (height above the seabed). From these
values, Ruskin will estimate wave frequencies and wave periods that your instrument could measure (period = 1/
frequency). On data retrieval, Ruskin will calculate the actual mean depth of water from the instrument altitude entered
and its depth measured using the pressure transducer, and then use this actual depth for computing all wave statistics
during deployment.

The physics of what a pressure transducer can measure depends on the height of water above as well as the depth of
water below it. High frequencies attenuate very quickly with depth. The depth of the deployment is critical in
determining frequencies/periods of the wave data the instrument will be able to capture. It is the depth, not orientation
of the pressure transducer that affects these measurements.

Depth (m)
0 5 10 15 20 25 30 35 40

1.000

—30sec
20 sec
10 sec

—5sec

—25sec

0.010 \ \ —1sec
0.001
|

Wave attenuation as a function of depth for various wave
periods

Attenuation
2
8

I —

Instrument fixed to a dock below the water surface

7.6 Download latest

There is a button on the Deployment tab labelled Download latest. This button downloads the latest dataset stored in
the instrument. This dataset could be still recording.

A ReRr recommends storing your data on a local drive ratherthan a network storage drive. Cloud storage options
such as GoogleDrive and Dropbox may extend download times.
Steps

1. Click Download latest. The file is automatically downloaded to the location specified in Settings > General, and
names it as it appears in the Datasets tab.

2. The new dataset will appear automatically in Navigator window under Datasets.

3. The Properties window will change to the dataset view, with the following tabs: Overview, Analysis, and
Channels.

4. All the data stored on the instrument at the time of the download will be automatically plotted in the Plot
window.
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When you download data again while on the same schedule, the RSK file will append it with any new data stored since
the last download. This default behaviour can be changed in Ruskin > Settings > General > Download options.

7.7 Enable/ Stop

Ensure that your instrument is ready to be deployed before enabling a schedule. See Deploy your instrument.

To allow the instrument to start logging, click
Enable. This button is at the bottom left of
the Deployment tab.

The Enable button will now read Stop. The status will

become "Deployment paused", "Deployment gated", or
"Sampling in progress", depending on the configuration.

Logging will start when one of the following occurs:
® The Now button is checked

¢ The Start time arrives

Status: (Instrument disabled ]
Clock:  2026-01-26 16:00:32 uTC Local
Start: Twist activation .
End: Gated
Battery:  None
Enable Download latest
Status: [Deployment gated ]
Clock:  2026-02-17 12:07:06
Start: v
Battery:
Stop Download latest

® The battery end-cap is turned to the run position, starting the Twist activation
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If the maximum number of deployments have been recorded, you will not be able to click Enable.

Before proceeding, download the data from your instrument (see Download).

All editable fields become greyed out after you enable a schedule.
To change any deployment parameters, stop your instrument, adjust the settings, and start a new

deployment.
To manually stop the instrument, click Stop.
Logging will stop on its own when one of the following occurs:
* The End logging time is reached
® The battery end-cap is turned to the pause position
* The power source is removed or depleted

e The memory is filled
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8 Calibration

Under the Calibration tab you can confirm measured and derived parameters for your instrument. It also displays
calibration coefficients for each parameter, the date and time of the last calibration, and all the parameters the RBR
instrument may need for calculating derived channels. Select a sensor from the table to display its calibrations.

Deployment Datasets Calibration

# Parameter Units Sensor Calibration date: 2026-02-17 15:35:05 Parameters
1  Temperature °C Marine 3
(2) Temperature ADC °C Marine £0 20000000 Fe2 [EREE e LL
C1 =250.0000000 E-6 Pressure (dbar): 10.1325
Cc2 2.7000000 E-6
c3 23.0000000 E-9 Atmospheric pressure (dbar): 10.1325
NO -1 Density (g/cm?): 1.0281
Offset: 0.0 Specific conductivity coefficient: 0.0191
Slope: 1.0 Average sound speed (m/s): 1550.744
Salinity (PSU): 35.0
Instrument altitude: 0.0
Save Undo Reset

Calibration certificates

If you see a warning sign on the Calibration tab, this indicates that the calibration is out of date and needs to be
recalibrated.

RBR calibration certificates contain calibration equations, coefficients, and residuals for each sensor.

The date of the latest calibration is always displayed. A warning sign will appear on the tab when your calibration
certificate is out of date.

RBR recommends calibrating your instrument before any critical deployment, periodically once a year, or if you suspect

the readings to be out of specifications.

Discuss your calibration requirements with RBR. In some cases, the instrument may need to be returned to RBR to have

it checked and recalibrated.

To contact RBR for our current calibration fees, click Request calibration quote and complete the Request for quote

form.
Calibration controls

You can edit the calibration coefficients, displayed as "C" values: C0, C1, C2, C3. As soon as you make a change and
move to another cell, a new calibration date will be displayed. Also, Save and Undo buttons will become active.

Use Save to save the new values.

Always click Save to save new coefficients on the instrument. Otherwise, all changes will be lost once your
session is closed.

Use Undo to recover to the original coefficients if you have not already saved your changes to the instrument.

You cannot use Undo after clicking Save. Once the coefficients are saved to the instrument, you will need to
restore old values manually and save them again.
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Parameters
The Parameters table displays all the parameters the RBR instrument may need for calculating derived channels.

If your instrument can measure a parameter, it will use the measured value. Otherwise, you can enter the necessary
values manually, and they will take effect immediately.

For example, you always need atmospheric pressure and water density for derivation of depth. Default values in Ruskin
correspond to sea level and sea water. Therefore, it is especially important to adjust these parameters when working at
high altitudes in fresh water.

Enter atmospheric pressure (in dbar) and water density (in g/cm3) manually in the table under the Calibration tab. If
not entered, default values of 10.1325dbar and 1.0281g/cm3 will be used.
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9 Settings

On your Mac, access Settings from the Ruskin dropdown & Ruskin File Instruments Help

menu in the top toolbar.
® | About Ruskin

On your Windows PC, use the Options dropdown menu File Instruments Options Help

to set up your preferences. 5 Navigator Preferences... = 0

Factory-set global defaults require no changes in most situations. However, as you learn more about what Ruskin can
do, you may want to change some of these settings to better suit your requirements. The global preferences include:

Derived channels (applies to some legacy instruments)

Facility (authorised users only, requires login)

General (download locations and options, sampling and calibration controls, export options)

Plotting (channel visibility and channel colours)

9.1 Derived channels

The Derived channels settings are intended for XR(X),1060, 2050, and 1050 RBR legacy data loggers. They do
not apply to newer generations. They do not apply to any RBRcoda or RBRcoda? instruments.
Newer generations calculate all possible derived channels for that specific instrument.

Use the Calibration tab in the instrument Properties window to set up initial parameters for calculating
derived channels. For downloaded files, use the Parameters tab in the dataset Properties window.

The Derived Channels section of the Preferences dialog box has four tabs: Depth, Conductivity - Salinity, Dissolved

02, and No sensor values, where you can choose additional channels derived from measured channels.

Derived channels calculated by the instrument as well as those calculated by Ruskin are automatically added to the
default channel list in both the live Plot view and the static dataset.

Depth

If your instrument has a pressure channel, you can use its measurements to derive a depth channel. The data calculated

for this derived channel appear along with measured channels in the Plot view and in datasets.

1. Select the Enable Depth Channel checkbox.

For newer generation instruments, all derived channels are calculated regardless of the checkbox
status.

2. In the Atmospheric Pressure box, type the value in dbar or use the default value. This value corrects the
pressure measurements during the depth calculation.
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The default Atmospheric Pressure value is 10.1325. Adjust this value manually to represent a different
altitude.

3. Select either the Simplified calculation or Seawater calculation.

Ruskin can calculate depth based on the simplified calculation or the UNESCO seawater calculation.
The instrument always calculates depth using the simplified calculation.

a. To use the simplified calculation, type the actual water density, or use the default value. Note that for
freshwater, the density should be set to 1.0.

b. To use the UNESCO seawater calculation, specify the latitude of the data collection in degrees and
minutes.

Conductivity - Salinity

If your instrument has a conductivity channel, you can use its measurements to derive salinity, density anomaly,
specific conductivity, and speed of sound.

1. Select the Use conductivity correction for derivation checkbox.

For newer generation instruments, all derived channels are calculated regardless of the checkbox
status.
2. In the Hydrostatic pressure box, type the value in dbar or use the default value.
3. Select derived channels to include in your calculations.
4. For the speed of sound, select between UNESCO, Del Grosso, and Wilson equations.
Dissolved 02
You can derive a dissolved oxygen channel that measures oxygen saturation as a percentage.

1. Click the Dissolved O, tab and select the Enable Dissolved Oxygen Channel checkbox.

For newer generation instruments, all derived channels are calculated regardless of the checkbox
status.

2. If your instruments use the Oxyguard DO or RINKO DO sensor, select the Derive concentration using the Weiss
equation checkbox and the output unit: uMol/L, mg/L, or mL/L.

The Weiss equation requires values for temperature and salinity. If your instrument does not measure
them, you can specify standard values on the No sensor values tab.

3. If your instruments use the Aanderaa Optode DO sensor to measure oxygen saturation, select the Derive
concentration using the Weiss equation checkbox and the output unit: mg/L or mL/L.

4. If any of your instruments use the Aanderaa Optode DO sensor to measure oxygen concentration, select the
Calculate saturation using the Garcia and Gordon equation checkbox.

The Garcia and Gordon equation requires values for temperature and salinity. If your instrument does
not measure them, you can specify standard values on the No sensor values tab.

No sensor values

Enter salinity, pressure, and temperature values used to calculate the derived channels when a sensor is not available.
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If you suspect that the derived channel value is incorrect, check to make sure that the No sensor values
entries match the deployment environment.

For example, if a dissolved oxygen saturation measurement is made in a lake at 8°C but the No sensor values
salinity is 35 and the temperature is 15°C, concentration reported will be incorrect.

Adjust the No sensor values entries and recompute.

9.2 General

Use the General settings page to set up file locations, language, download options, sampling and calibration controls,
and export options.

° You can click Apply to save your changes without closing the dialogue box.

File location
You can control where RSK files, realtime RSK file, and log files are stored by default.

Specify these locations before downloading any data by typing in a directory name or by browsing.

File location

Directory for RSK downloads /Usersfjchapman/Downloads Browse...
Directory for realtime RSK files /Usersfjchapman Browse...
Directory for log files [Usersfjchapman Browse...

*Takes effect on the next file stored

RSK files are the datasets obtained from your instrument.

Realtime RSK files are generated when a connected instrument is streaming or when you enable fetching mode on the

instrument.

Log files are generated by Ruskin and help when diagnosing issues. These files are automatically attached to issues
generated using the Comment on Ruskin feature.

RBR recommends storing your datasets on a local drive rather than a network storage drive. Cloud storage
options such as GoogleDrive and Dropbox may extend download times.

You can change where future files are stored by default at any time. When done, click Apply or Apply and close. The
changes will take effect immediately.
Language selection

Ruskin is available in six languages: English, French, Spanish, Simplified Chinese, Korean, and Japanese.

Language selection

v English ) (restart required)
Frargais
Espafiol
b schedule Ul
#29 = ,
in RSK files produced using the auto download feature
i3

_Jend new downloads to existing RSK file with matching deployment
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Select your language from the dropdown menu and click Apply or Apply and close. Ruskin will need to restart for the
changes to take effect.

Download options

Select the appropriate checkboxes to change your download preferences.

Download options

V' Enable download schedule Ul
Automatically open RSK files produced using the auto download feature

v Automatically append new downloads to existing RSK file with matching deployment

The Enable download schedule Ul checkbox is only for legacy instruments.

When done, click Apply or Apply and close. The changes will take effect immediately.
Export options

Select the checkbox to enable raw data export. Use this option for downloading your RSK file when storage space is
limited or expensive. The dataset will be exported in the most compact raw binary format.

When done, click Apply or Apply and close. The changes will take effect immediately.

9.3 Plotting

Adjust default settings for the graphical display in the Plot view. Manage selections in Channel visibility and Channel
colours, and apply them globally.

° You can click Apply to save your changes without closing the dialogue box.
Channel visibility
The Channel visibility tab displays many options to hide or show specific information.
Opt for displaying errors and events for a more informative graph, or hide them for a cleaner view.
Select the By default, hide all measured channels checkbox to display only derived channels.
Select the By default, hide all derived channels checkbox to display only measured channels.
Otherwise, pick and choose channels to display or hide.

When done, click Apply or Apply and close. The changes will take effectimmediately.

You can override visibility preferences in the Plot view for any particular graphical display.

Channel colours

The Channel colours tab allows you to choose a different colour for each channel that is shown for information
currently running in Plot view, or from an opened dataset. Select from the list of pre-defined options or create your own
colour.

When done, click Apply or Apply and close. The changes will take effectimmediately.
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10 RSK files

The RSK file is a single file database based on SQLite that allows us to have large files with high-speed access to any part
of the dataset. RSK files have different types and versions, which reflect historical changes to the underlying dataset
structure. To upgrade the version of an older RSK file, go to Overview tab.

RBR provides open-source RSKtools toolboxes for both Matlab (RSKtools) and Python (pyRSKtools) to read, post-
process, visualise, and export RSK files.

RSK files can be exported to Excel, OceanDataView®, or text files.

RSK files contain data recorded by the instrument or sensor, firmware and software versions, dates and times, sampling
settings, power settings, measured and derived parameters, errors and events, other diagnostic information.

For datasets obtained via streaming or polling, the RSK format is Realtime. Their file names contain the "realtime"
label.

This file format is available for RBR standard instruments and RBR realtime sensors when in streaming mode, and for all
instruments when polling.

0 Datasets recorded in Calibration storage format allow changes to calibration coefficients. You must explicitly
select this option if you wish to manipulate calibration coefficients after the data has been recorded.

o GPS mapping for RSK files relies on manually added location points.

To identify the type of the RSKfile, go to the Overview tab.
File naming convention for datasets obtained during deployments
By default, RSK file names are composed of the following information:
® The instrument serial number: six digits
¢ The date of the deployment (YYYY-MM-DD): eight digits
¢ The time of the deployment (HH-MM in the 24-hour format): four digits

For example, the file named 209681_20260204_1306.rsk contains the dataset for an instrument with a serial number of
209681; the start time of the deployment was February 04, 2026 at 13:06 (01:06pm), local time.

The data recorded from the current and previous deployments are stored in the instrument. They can be accessed
(downloaded or deleted) from the Datasets tab. You can also download the latest deployment from the Deployment
tab. Download them to your computer before starting a new deployment. Go to Preferences > General to change your
default location for RSK downloads.

0 RBR recommends downloading deployments as soon as possible to ensure data is recorded in a safe location.

File naming convention for realtime datasets

By default, realtime dataset names are composed of the following information:
® Theinstrument serial number: six digits
® The date of the download (YYYY-MM-DD): eight digits
e The time of file creation (HH-MM in the 24-hour format): four digits

e The "realtime" label, indicating the data were streamed or fetched from the instrument

For example, the file named 209682_20260205_1408_realtime.rsk contains the dataset for a streaming instrument with
a serial number of 209682; the data collection started on February 05, 2026 at 14:08 (02:08pm), local time.
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The data streamed or polled from your instrument are automatically saved to your computer. Go to Preferences >
General to change your default location for realtime RSK files.

The file extension is .rsk; it indicates the Ruskin file format and must not be edited. If you change it, your new
file extension will become part of the dataset name, and the .rsk extension will be appended.
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11 Realtime data format

Real-time data is data that is either automatically streamed from the instrument during a deployment or
asynchronously polled from it. Streaming is only available for instruments with an underwater data connection. Polling
is available on all units.

When polled data is the only live option on the instrument, the data will have the following format:

<Timestamp> <valuel> <value2> ... <valueN><CR><LF>

Example:

2026-02-04 07:55:32 23.3254 10.1149 0.1149 0.1149

This is an example of an RBRduraturo® T.D polling all channels (temperature_00, pressure_00, seapressure_00,
depth_00)

If the instrument supports streaming over an underwater connection, the format of the live data will be identical
between both streamed and polled samples. The instrument provides the flexability to change the format of the output
for different applicaitons, however, the default format for streamed data set via Ruskin will be the following:

<schedule label> <Timestamp> <valuel> <value2> ... <valueN><CR><LF>

The schedule label is important to differentiate the schedule from which the data came when deploying an instrument
with multiple schedules.

Example:

sch_Pressure 2026-02-04 08:00:00 10.1149 0.1149 0.1149
sch_Temperature 2026-02-04 08:00:00 23.3254

In this example, the RBRduraturo® T.D has been deployed with two schedules and both are set to stream. The
Temperature channels are on one schedule and the Pressure channels are on another. The schedule label allows the
parser to associate the streamed data with different schedules.
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12 Dataset files

Datasets are RSK files generated by Ruskin and have an .rsk extension. After downloading your datasets, you can view
and analyse your data using the options below.

‘ Ruskin  File Instruments Help

Go to the File dropdown menu to open or close a

. . [ XN J
dataset, export your data, and see the list of available P S e il
Navigator
datasets. # Instrumer  Export >
win MLM |

& Datasets  1: 908190_20251218_1448_realtime.rsk
@ Calibratic 2: 907951_20251209_1437_realtime.rsk
3: 901814_20250616_1638_realtime.rsk

The Datasets context menu in the Navigator windows # Navigato\r = =
duplicates some of these options for convenience. »

i Instruments
s MLM
A/ 'Datasets

B 208190... Close dataset \ -

@ Calibration fa
Export >

Reset chart view

When a dataset on the list is selected,

the Properties window displays three tabs with \ Overview {Analysis"""”"* Channels

information related to this dataset.

Use these tabs to analyse your data, check the
calibration certificates, and verify your parameters.

12.1 Open dataset

Open any stored dataset from the File menu in the top toolbar or from the Datasets menu in the Navigator view.

Steps
. @& Ruskin File Instruments Help
1. Select File > Open dataset
@ o Open dataset
44 Navigator )
@ Instrumel  Export >
s MLM

. Datasets 1: 908190_20251218 1448 _realtime.rsk
@ Calibratic 2: 907951_20251209_1437_realtime.rsk
3: 901814_20250616_1638_realtime.rsk

Alternatively, right-click Datasets in the Navigator P Navigatof = (m

view and select Open dataset.
‘ @ Instruments

wim MLM

opsndataiset o M

© Calibr
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4 Navigator = O || 241114_20260204_0316.r5k 2

2. A browsing window will appear. Double-click 4 s e
MLM
the .rsk file you want to view, or select the file and
. Time 2026-02-04 08:17:26.000
click Open.
3. The name of the dataset appears and is
highlighted automatically in the Navigator vi O e —
Ighlighted automatically in the Navigator view. s
4 Dissolved O, concentration 251.8067932 umol/L.

The Properties view changes to the dataset view, Coreceaph 70367004
with four tabs: Overview, Analysis, Channels,

and Calibration. It will open to the Analysis tab

by default.

4. The data in the file will automatically appear in
the Plot view.

‘," M \A\;\/\‘\Ji;\f ) ”‘ V/\'AM '\’f\ M /\

i

}“\’W"n’/‘\"' = i Mamba el /’“*w,\’\mwx/\-/\..‘m/\'m/\,wv\/\p /\/\/\.]

° To close a dataset, go to File > Close dataset. Alternatively, right-click the dataset name in the Navigator view
and select Close dataset.

Alternatively, simply close its Plot tab by clicking the X. The dataset will disappear from the list.

12.2 Export

Use the Export option to share your data with others or analyse your data using other software. Datasets can be read
directly in Matlab with our toolkit RSKtools, or exported to Excel, OceanDataView?®, or text files.

Steps

1. File menu > Export, then hover to open a set of submenus.

® Ruskin File Instruments Help =

ece Open dataset Ruskin v2.26.0.202602091216

|48 Navigator Close dataset
|

# Instrumen’ Export >  Annotations >

| & 0 MicrosotExcel (o0
v ICrosof xcel (*.xIsx; rofiles
| v S Datasets 1. 980001_20260126_1047.rsk
| f 98000 (*]
2: 241114_20260204_0316.rsk
(<}

3:241227_20260130_1509iCcal (2).rsk
4:240732_20260204_1426P.rsk
5: 240734_20260204_1418P.rsk
6: 240733_20260204_1419P.rsk

;):_! Text (*.zip)
[# OceanDataView spreadsheet (*.odv)
Raw binary (*.bin)

7: 241530_20260115_1020_1_2P_data_moved_schedules (1).rsk :)?Isg dbna(;
8:240214_20260129_1308_realtime (1)FL.rsk 5389 dbar
9: 200402_20260119_0952FI.rsk 7858 °C
[ rrressurs w2738 dbar

6 Temperature 23.6056271 °c

7 Sea pressure . dbar
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or right-click the dataset in the Navigator window, then hover to open a set of submenus.

r. @ Ruskin v2.25.0.202602091216
% Navigator ~ O |21 980001_20260126_1047.rsk 52
# Instruments Overview | Analysis ._Channels | Calibration
wam MLM -
v eDatasets
B 980001,
Close dataset Time 2026-01-26 10:46:45.000-05:00
Export >  Annotations > B
Reset chart view @ Microsoft Excel (*.xIsx) Profiles >
lue Unit
0_ 8O dbar
=) Text (*zip) 89 e
[# OceanDataView spreadsheet (*.0dv) 89 dbar
o
@ Raw binary (*bin) 2? I e
33 apar
[I" 6 Temperature 23.6056271 °c
7 Sea pressure - dbar
8 Depth - m

2. Select the appropriate export format (Microsoft Excel, netCDF/netCDF profiles, Text, OceanDataView

spreadsheet, or Raw binary).

For realtime RSK files, the Raw binary export format is not available.

3. If exporting annotations, select the category: Full profiles, Downcasts, or Upcasts.

4, Specify a location and a name for the data file.
5. Click Save.

12.3 Analysis
Select a dataset in the Navigator view.

The Properties view will change to dataset properties,
with three tabs: Overview, Analysis, and Channels.

The Analysis view contains statistical information about

deployment, as well as information about the dataset Time

channels and their values.

The colour-coding of the channel table matches that of
the traces in the Plot window. To change the colour
settings for your chart, go to Preferences > Plotting >
Channel colours.

Overview | Analysis

Selected time range:

# Channel
1 Temperature

Channels

2026-02-17 07:37:43.500

Display statistics

Value Unit
21.6648560 °C

Move the black cursor ("double lollipop") in the Plot window to display parameter values for each sample selected.

Every time you move the black cursor, going from sample to sample, the table above the plot will display the

information for this particular sample.
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4 Navigator . = 0| 71239090_20260217.0737.rsk 3¢ = 0|
# Instruments Overview /Anal i
ysis . Channels
s MLM
N .Datasets Cursor
416 239090....rsk
Time 2026-02-17 07:37:31.000
Display statistics
Selected time range:
# Channel Value Unit
1 Temperature 21.7842712 °C
i 239090_20260217.0737.rsk 52 e - - I RA- % @QLAQCQR QOB E-me g0
21.795
O 21790
21.785
5 2n7m0
® 217
Q 21770
5 21.765
21.760
21755
07:37:28.500 07:37:29.000 07:37:29.500 07:37:30.000 07:37:30.500 07:37:31.000 07:37:31.500 07:37:32.000 07:37:32.500 07:37:33.000 07:37:33.500 07:37:34.000
Time
L]
A

Select Display statistics checkbox to determine the average value and standard deviation over a range of samples.

Change the selected time range of samples to average using the up and down arrows or by clicking in each of the hour,
minute, and seconds fields to edit the time manually.

The table will display the averaging data. The averaging interval will be highlighted in the plot.

4 Navigator = 0O |/ 239090_20260217_0737.rsk zz\\ =g
@ Instruments Overview | Analysis . Channels}
wam MLM
v & Datasets Cursor
1019 239090.....rsk
Time 2026-02-17 07:37:34.500 - 2026-02-17 07:37:44.500
Display statistics
Selected time range:  00:00:10 <
# Channel Value Avg Std Unit
1 Temperature 21.6602783 21.6958298 0.0289927 Sl
B 239090_20260217.0737.rsk 2 . e - -2 NA-% exeaeReB B oy L=-0
21.800
I —ﬂ
o 2750
5
S 21700
@
a
£ 21650 \\
@
=
21.600
07:37:25 07:37:30 07:37:35 07:37:40

7:37:45 07:37:50 07:37:55
Time

] I - : |
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12.4 Overview

Use the Overview tab to view general information for each dataset, including instrument firmware and serial number,
enabled schedules, deployment events, and details about the file itself.

12.5 Channels

For, non realtime datasets, the Channels tab will have
three options: Information, Calibration,
and Parameters.

For realtime datasets, the Channels tab has two options:

Information and Parameters.

The Information page displays two tables: Measured
channels and Derived channels.

Measured channels include measured parameters with
their units of measurement, the sensor manufacturer,
and the range setting (if applicable).

Derived channels include all available derived
parameters with their units of measurement and the
methodology used to calculate them.
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Overview | Analysis | Channels

Information ~ Calibration ~ Parameters
Measured channels

# Parameter Sensor Range
1 Temperature (°C) Marine nfa

Overview | Analysis | Channels

Information Parameters
Measured channels

# Parameter
1 Temperature (°C)

Sensor Range
Marine n/a

Overview | Analysis | Channels

Information ~ Calibration = Parameters
Measured channels

# Parameter Sensor Range
1 Pressure (dbar) nfa

Derived channels

# Parameter Notes

2 Sea pressure (dbar)
3 Depth (m)

Measured channels

# Parameter Sensor Range
1 Pressure (dbar) n/a

Derived channels

# Parameter Notes
2 Sea pressure (dbar)

3 Depth (m)
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The Calibration page displays the calibration and
correction coefficients (as applicable) for each channel,
along with the date and time of the last calibration.

Select a sensor from the Parameter dropdown menu to
display its calibrations.

Information  Calibration ~ Parameters

Parameter  1: Pressure @
Calibration date: 2000-04-01 00:00:00
Label value Label value
offset 0.0000000 co 0.0000000
slope 1.0000000 c1 1.0000000
c2 0.0000000
c3 0.0000000
Information  Calibration ~ Parameters
Paramete (AL )
Calibral 2: Sea pressure o
3: Depth
Label Value Label Value
offset 0.0000000 co 0.0000000
slope 1.0000000 c1 1.0000000
c2 0.0000000
c3 0.0000000

The main calibration coefficients are displayed as "C" values: C0, C1, C2(K). Dependent coefficients are displayed as "X"

values: X0, X1, X2, etc.

o Both offset and slope are editable in any dataset format. Other coefficients are only editable when recorded in

calibration mode.

As soon as an edit is made to a coefficient cell and
another cell is selected, a new calibration date will be
displayed. Also, all three buttons at the bottom of the
page will become active.

Use Store and recompute data to recalculate the
dataset. Use Revert calibration to restore the previous
coefficients that were not saved.

To restore the calibration used during the deployment, if
a new calibration has been stored, check the Use
deployment calibrations checkbox. Click Store and
recompute data to save the coefficients as the latest.

The Parameters tab displays parameters necessary to
calculate derived channels and the method used for
calculation.

You can edit these parameters to change the derived
channel calculation. As soon as you make a change, the
two buttons at the bottom of the page will become
active.

Click Update and recompute to recalculate the data and
display new values.

Use Revert settings to recover the previous coefficients
and data if you have not already selected Update and
recompute.

o This page is not editable for realtime datasets.
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Information ~ Calibration ~ Parameters

parameter  1: Pressure %]
Label Value Label Value
co 0.0000000
slope 1.0000000 (e 1.0000000
C2 0.0000000
c3 0.0000000

Store and recompute data Revert calibration Use deployment calibrations

Store and recompute data Revert calibration Use deployment calibrations

Overview  Analysis Channels
Information  Calibration ~ Parameters

O simplified depth derivation
Seawater depth derivation

Atmospheric pressure (dbar)  |10.1324.

Density (g/em?) 1.0260

Latitude (degrees) 00

Speed of sound type UNESCO e
Specific conductivity coefficient 0.0191

Oxygen concentration units mg/L [2)
Salinity 350

Absolute pressure (dbar) 10.1324
Temperature (°C) 15.0
Average sound speed (m/s) 1550.7440

Update and recompute Revert settings
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13 Dataset plot toolbar

Use the plot toolbar to adjust the display of an open dataset.

Cast
detection Appearance
l Zoom controls controls
| == Gl Avlea @ @ Q@ _,e ¢l |8 Er=
Annotation T T T
controls Event Export GPS
visibility plot map

13.1 Annotation controls

Annotations are information messages added either by users or by the instrument.

Create annotation

Filter Index l

e € 3/557|l}lb|\»'
f

Navigation buttons

Proflle (557)

13.1.1 Select annotation type

Annotation types are divided in two categories: profiling (Profile, Downcast, or Upcast) or non-profiling (Comment,
Exclusion, Location, or Calibration). Use annotation controls to manage this information and to navigate the plot.

Type Function
Profile, Downcast, Upcast Identify profiling
Comment Add a note to your data
Exclusion Remove a non-representative interval from analysis
Location Add in latitude/longitude coordinates for RSK files to track locations of data
logging
Calibration Calibrate the ODO sensor
RBR#0020214revA
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Open the Filter dropdown menu to select the annotation
type to display. The number of annotations for each type Locatlon (1) v
will be indicated. Locatlon (1)
Proflle (557)

Downcast (557)
)

Select an annotation type. The plot will centre on the first item in the selected category. For example, when you select
Profile, the plot will move to the first profile.

If you switch the filter to another annotation type within the same category (for example, Profile to Upcast), the plot
will not change. If you switch to a type from another category (for example, from Profile to Comment), the plot will
move to the first annotation in the new category (for example, to the first comment).

13.1.2 Navigate between annotations

& € 552 | 557 D B

Use the Navigation buttons to navigate between items within the selected category.

The navigation buttons will be activated if there is more than one item in the selected annotation type.
Otherwise, the plot will centre on the only item available.
Navigation controls
* Move from one annotation to another by clicking the left and right arrows.
¢ Jump all the way to the beginning or end of the list by using the end-left and end-right arrows.
¢ Alternatively, manually enter the number in the Index field to go to that particular annotation.

¢ Double-click an annotation to centre and zoom in the plot at that particular area.

ﬁ 203672_20220517_1240.rsk &3 ﬁ 203672_20220517_1240.rsk &3

[ conme <er T A x)

== g
o ==

COMMEN <er T AUX)

Temperature (°0)
Temperature (*0)

AV nm'wrw meaw |

Time i

° Double-click anywhere on the main plot to return to the full-chart view.

13.1.3 Create new annotation

Click the Create annotation button ~ " and follow the steps below.
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a8
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Steps

1. Select the type of annotation to create, for V) | Cv R A @
example, Comment. i
The cursor in the Plot window will become a two- . . | m ]
way arrow . : . Location

Profile
Exclusion

2. Click on the main plot to identify a single point to comment (1) [¥ 1 B G v
comment, or click and drag the cursor left or right
to select an interval. When you release the click,
an editable tooltip will open.

(.;,O..MMENT 1 er W IvX
Title Comment 1|
Details
2016-12-1522:04:13  2016-12-15 22:04:13
I
. 2 7] iz . "
The tooltip controls include Left and Right arrows , Delete , Export region , Save ,and
Close X .
The Profile tooltip also features Up and Down arrows YA for adding upcast and downcast profiles.
3. Enter the necessary information into the fields Comment (1) [& W

and save by pressing Enter on your keyboard or

by clicking Save v on the tooltip. Your new
comment will appear in the dropdown list.

Protile (1)
Downcast (1)

x

or pressing Esc on the keyboard will close the tooltip without saving.

&

¢ Clicking Close

¢ Click the arrows on the tooltip to move to the next annotation within the same category.
* Double-click on the annotation bar to zoom in to the range of the annotation.

¢ Click and drag on the annotation bar to move the annotation.

¢ Click Delete on the tooltip to delete the annotation. A warning message will appear.

® Click Delete to proceed. This action cannot be undone.

RBR#0020214revA
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Edit at least one detail in the tooltip before saving. Otherwise, the annotation will be deleted when
deselected. Moving or resizing the annotation counts as editing and saving.

13.1.4 Add profiles

Use the Annotation function to manually add profiles to your dataset.

Steps

1. Click the Create annotation button

and select Profile from the dropdown menu.

2. Click and drag the cursor to select a region.
As soon as you let go, an editable tooltip will open
and a band of a darker colour will appear above
the selection, indicating that a new profile has
been added.

3. Place the cursor on the edge of this new profile
and move it left or right to adjust the size.

v

4, Add a name and click Save on the tooltip.

RBR#0020214revA

1 ) LA @

Comment

Location

Exclusion

-- = v i Ay @y @ ;{ i .‘\;. _;J

—

Profile (1) |v
b
PROFILE1T Y A “&r T A X
Title
Details
2016-12-1517:17:58  2016-12-16 01:45:01
Profile (1) [¥ d G e Ay @
N
N
\¥
PROFILE1 Y A “or T AU X
Tite 10X
Details

2016-12-16 02:20:09  2016-12-16 03:59:19
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5. Use the Up and Down arrows

' A on Downcast (1) [a 1 Gy Av @

Comment (1)
the tooltip to identify upcast and downcast Profile (1) l

regions.

The upcasts and downcasts you added will be
displayed in the dropdown menu and highlighted
on the plot under the parent profile.

Only the Profile tooltips have the Up and Down arrows.

6. Place the cursor at the edge of the added region /1 TYIR Ay @@ Q@ Q@ Qg2
and adjust its size.

7. Click on a profile/upcast/downcast to open its
tooltip.

8. Name each region and save the settings.

9. If desired, export your profile to a separate RSK file. To do that, click Export region on the Profile tooltip
and follow the steps.

The Export region option is not available on Upcast and Downcast tooltips. To generate an RSK file for an
upcast or downcast section only, use the Comment annotation to clip the dataset before exporting.

13.1.5 Exportregion

The Export region option is only available for Comment and Profile annotations.

Follow the steps below to clip your dataset and export a subset of your data. This function may be useful when you

need to exclude certain regions. For example, a dataset may contain several deployments if sampling was not paused/

stopped before the new deployment was started.

RBR#0020214revA
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Steps

1. Click the Create annotation button ~ " and
select Comment from the dropdown menu.

2. Click and drag the cursor to select a subset.

3. Enter a name in the Title field on the tooltip and

J .

click Save

4. Select Export region
A dialogue box will open.

on the tooltip.

5. Adjust the name and location for the new dataset
file and click Save.
An Export region message will appear.

6. Select No to maintain the full binary values and
retain the option of recalibration in the future.
The clipped dataset will openin a new tab in the
Plot window.

RBR#0020214revA

€ /1M I RALG

8| Comment Jams

Location

Profile

Exclusion

comment (1) [v! | 1 R | &~
A
AN
COMMENT 1 e T A/X
Tite  Clip
Details

2023-01-23 08:19:49  2023-01-23 09:19:05

I

save As: | 3976_20230123_1018P clipped.rsk |

Tags
Where: [ Downloads e -

Ruskin RSK (*.rsk) =)

° Export Region

1 Do you want to strip out the original downloaded image to reduce file size?

No Yes
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13.2 Cast detection

Ruskin automatically enables profile detection on instruments when a deployment is enabled. There are several criteria
for enabling this feature.

¢ Theinstrument must support the castdetection setting

¢ Theinstrument must have a pressure sensor

* The deployment must be configured for | fast sampling (2Hz and up)

The deployment mode must be configured as either continuous or directional
It is possible to recalculate the casts in a dataset using the cast detection feature in the Plot view.

Click the Cast detection button N to run a cast detection algorithm based on depth and conductivity to
automatically generate profiles and casts. A warning message will appear.

[ ] Cast Detection - Are you sure?

Warning!

The cast detection operation will replace all instrument-generated profiles/casts, even those that have
been edited, and may take a long time to run.

Are you sure you want to proceed?

If you proceed, Ruskin will find peaks, collect events, and overwrite profiles recorded by the instrument.

° Double-click anywhere on the main plot to return to the full-chart view.

13.3 Event visibility

Click the Event visibility button A~ to turn on and off the visibility of the various levels of events: Error, Warning,
Information, and Diagnostic. Its colour will reflect the highest level of event severity reported.

A @@ @ @ad A @ @ @ ad Arla e b el
1 4k E (0) F 1 £\ Error (O) : : £y Error (0) :
Warning (0) m , Warning (0) -« /A Warning (1)
Information (0) v /\ Information (2) " v /\ Information (1)
v /\ Diagnostic (23) ' /\ Diagnostic (2228) - : Diagnostic (0)
[ S : o i
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13.4 Zoom controls

Default scaling of the plot is based on the minimum and maximum values sampled for each channel. Use zoom controls

to adjust it as needed.

Zoom out

. Reset zoom
. horizontally .
Zoom in to maximum
horizontally bounds

v

v

LT

T

Zoom in
vertically

)

Toggle
auto-ranging

Zoom out
vertically

[ Double-click anywhere on the main plot to return to the full-chart view.

13.4.1 Horizontal zoom

Horizontal scale options may be helpful to increase or decrease the the time range displayed. It is convenient when the
dataset is long and thus losing resolution when displayed in the Plot window in its entirety, like in this example.

i 095719_20170323 112115k 3 7 G A w6 6@ e e s o0

There are three ways to apply changes to the horizontal scale. The first two will auto-range your chart, ensuring the
entire vertical domain is visible. The third approach will retain the latest vertical scaling of the original interval.

1. Use the Zoom in horizontally and Zoom out horizontally buttons.
OR
Click on the thumbnail view and resize the indicator. The vertical scale will automatically adjust to fit the new
range.

G-RA e @GR O B-H-00 =0

. o

IH | | ! Mt ‘ / I | I
) ’ 1“ ] ww‘]‘;m\‘\;“JJ\L{ “H'i‘ Mulu\‘wm\ il ‘;\1 W"M “‘Iw r"‘”“wu wvww\ i }“ W‘W ‘”u ]‘

S ul
“ “WMW e

Time

3 a0 [z w52 1056 w0 o o 110
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2. Hover your mouse over the X-axis, then hold Shift + left click.

The cursor will change to a two-way arrow . Dragit right to zoom in or left to zoom out the time domain,
without changing the data resolution.

i 095719_20170323 1121.rsk 3 i = CTRA-@2QAQR & B-EHo g

Click Reset zoom to maximum bounds = or double-click anywhere on the chart to restore the original
appearance.

13.4.2 Vertical zoom

Vertical scale options may be helpful when there are erroneously high or low values that make the real data appear
incorrect, or when there is significant difference in scale between the displayed parameters.

i 095719_20170323 112115k 3 I A @w § &wm e Bk o0

Entire chart
Depending on the zooming method, you may change the scale only vertically, or both vertically and horizontally.

¢ Use the Zoom in vertically and Zoom out vertically buttons to increase or decrease the resolution of the data
displayed.
The resulting display will retain the same horizontal scale.

il 095719_20170323_M21.rsk % ! GRA-@QITA & B-Ho

e — ]

* Hover the cursor and scroll your mouse wheel up and down to change the scale.
In this case, the horizontal scale will also change (as seen from the thumbnail indicator). The plot will centre
where the mouse cursor initially was.
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o w7 0 o wn w25 w27 o) w31 wn
Time

o |
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Individual channel

There are two ways to apply changes to the vertical scale of one channel only, which yield the same results.
® Hover the cursor over the Y-axis for this channel and scroll your mouse wheel up and down.
¢ Shift + click the Y-axis for this channel and move your mouse up and down.

This particular channel will zoom in and out (in the example below, temperature). Double-click on the same vertical
axis to reset this parameter.

B 095719_20170323_1121.rsk 22 B 095719_20170323_1121.rsk £
0.250 21.890 0.250
10350 10350 21845
0.200 21.860 0.200
21.870 21.840
10.300 10.300 .
E 0.150 O 21.860 ’s 0.150 O 21.835
-] T 10.250 {7 21850 o T 10250 {7 21.830
= T 010013 @ 21.840 = T o108 P
£ p s v 2L £ = T ¥ 21825
= = 10.200 {3 21.830 - s 10.200 {3
= 2 ooso{® = = 2 o050 © 21820
7 3 2 1015018 0 o g 2 101508 21815
o a 0% E 21.810 8 £ 0l g I
o a U o a o 21810
P 10.100 {2 21.800 ,, 10.100 {2
A -0.050 21.790 A -0.050 21.805
10.050 21.780 10.050 21.800
-0.100 by -0.100
100001 oo 10000{ 247
-0.150 - -0.150 21.790
09:31 09:33 09:35 09:37 09:31 09:33 09:35 09:37

Click Reset zoom to maximum bounds =

appearance.

or double-click anywhere on the chart to restore the original

13.4.3 Navigation options

After you change the scale, some parts of your chart may end up outside the Plot window. There are several options
available to navigate it.

® To pan the entire chart horizontally, hold Ctrl + left click and move your mouse left and right. This action is only
possible after already applying some horizontal zoom to the chart.

W 095719_20170323_1121.rsk 3 . i 095719_20170323 1121.rsk 3
11.000 - — =
10.400 TR
Lo zaof, - o Rleaidiiily 0 7
oso) 1080] 2200 5
21980
o 0601 106001 1060 | 0200
8 osois O 2100 |8 a0
s 5 10400 (< s 3
g = 0200 @ 21920 £ 2 o600
E o T g it T
5 5 ojy o3 nmo S oy
£ -0200{2 100008 % 18 1000 {2
a & g 21860 7y g 2
8 .0.400 {& 2 _y200{8
] & 0.800]9 21840 is IS %
& -0.600 s & 1400 >
] 1720
-0.8001 96001 53400 16001  9.000 >
1.700
-1.000
oa0] 2170 il 1 ase0, 1680
-1.200 21760 4 + E) h ;: ¢t 2,000 o S LRI ENes W o VSR oot
09:25 09:30 09:35 09:40 09:45 09:50 09 09:25 09:30 09:35 09:40 09:45 09:50 0
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¢ To pan the entire chart vertically, hold Ctrl + left click and move your mouse up and down.

ﬁ 095719_20170323_1121.rsk 23 = W 095719_20170323 _1121.rsk &
11.000 - - - - - - 1200 o
.1 1000 220201 i 11.000 25 020 M
| 108001 2200 X §
0.800 22.000
| 21,980 osof 1040 21.980 WM
T 0s00 1 I
| 10.600 21980 T 0.600 10.600 1~ 21 960 &
|8 o4l O 2100 2 = |2t i
= | 10400 |~ R 5 0400{m T 21040 W
|~ 0.200 S w 21920 = = s 10400 { @ P
S o0l = 3 v = < 2192
‘; 04w 1020012 21900 = 0.200 = 5
= 3 ¥ s : 2 0] 10200{F 21900
& e 5 T 21880 8 4 <l b
< & -02001 4 10.000 v 3 @ g 21880
0 s 2 21.860 a £ -0200{% 10000{2
{asaes T 21840 @ ou0 & e
9.800 -
| - = 2180
“.X 0.600 sie0 & e 9.800
| -os00 9.600 21.800 21.820 4
0.800 9.600 1.800
1 ~1.000 21780
‘ 9.400 1.000 21.780
| 1200 21760 9.400 ”

09:25 09:30 09:35 09:40 09:45 09:50 09 0905 09:10 09:15 09:20 09:25

09:30

¢ To pan one of the channels vertically, click a value on the vertical axis for that parameter (in the example below,
sea pressure) and move your mouse up and down.

ﬁ 095719_20170323_1121.rsk £3 ) - ﬁ 095719_20170323_1121.rsk ?K
| L0060, 200{ n 2 T T 7 0.600
'i ;: 10.800 22.000 g " 0 i
o ool o] dime -~ o
Ll B . E g
;J 15':04005 :é' ngﬂm‘éz
| 0500 SiEE =
‘\ v:m A:i:: e
| o aw{
: 09:25 09:30 0935 09:40 09:45 09:50 09 e ovas 09:30 0935 0940 09:45 09:50 09
Double-click on the same vertical axis to reset this parameter.
e To freely select any part of the chart, hold Shift T R —
+ left click and draw the rectangle. The chart will ’ |
zoom in on the selected area, both horizontally
and vertically. e ’1
i 095719 20170323 1215k 23 TADy ]
® To keep all your data within the viewing window, click the Toggle auto-ranging button =% Whenitis on, all
profiles within the selected time section maintain their optimal vertical zoom.
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¢ Click again to disable. Disabling the auto-ranging of the axis can be useful for looking at trends in data.
Zooming in or out of an individual channel will disable auto-ranging for that channel.

® To zoom in to the range of an annotation, double-click on the annotation bar.

Click Reset zoom to maximum bounds = or double-click anywhere on the chart to restore the original
appearance.

13.4.4 Advanced axis controls

By default, Ruskin will use a single axis to display similar ‘l s Sstscences
. . . . . Plottin,
channels. To display each similar channel on its own axis, e—— Ma:agide'a it b
go to Settings > Plotting > Channel visibility. Deselect oo Channelviibity JCRaSIESa0
the Use single axis for similar channels checkbox. o e R
Click Apply and close. These changes will automatically Show dataset erros by defaut
Automatically save live data to a file (Legacy instruments)
apply to every new dataset. To apply your changes to an s
active dataset, close it and then re-open. e L
Hide pressure channels Hide turbidity channels
Hide dissolved 02 channels Hide voltage channels
Hide distance channels Hide RBRquartz* period channels

Hide fluorometry channels
Hide pH channels
Hide PAR channels

By default, hide all derived channels

Hide salinity channels Hide distance channels
Hide depth channels Hide dissolved 02 channels
Hide pressure channels Hide RBRquartz® pressure channels

Hide specific conductivity channels Hide RBRquartz® temperature channels
Hide speed of sound channels
Hide density anomaly channels

Restore Defaults Apply

Cancel Apply and Close

Both views have their advantages. Below, compare the two displays of the same dataset obtained using an
RBRquadrante .

Default settings: single axis

The chart displays four irradiance channels and one irradiance axis. The axis is grey, while the traces related to this
single axis remain colour-coded.

With the axis panel collapsed, you have a broad view of the chart.
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All four channels have the same scale, which in the example below is 0-5.500uW/cm?/nm. Vertical zoom controls, if
used, are applied to all these traces as a group.

powncast3) v @ @ 2 | 3 D B T-RA @@ Q& QA QL & BrEHy 0

80.000

75.000

70.000 1, 5,
\
4.500 65.000 1 N

60.000

55.000 \

50.000 N

45.000

40.000

Pressure (dbar)

35.000

30.000

Irradiance (uW/cm? /nm)

25.000

20.000 ™

15.000

10.000

15:18:30  15:18:35  15:18:40  15:18:45 15:18:50 15:18:55  15:19:00 15:19:05  15:19:10 15:19:15  15:19:20  15:19:25  15:19:30  15:19:35
Time

Customised settings: multiple axes

The chart has four irradiance channels and four axes, each identified with the same colour as the trace. The
corresponding wavelength and FWHM will also be displayed; in this example: 560/10, 488/10, 445/10, and 413/10.

Each channel has its optimal vertical scale. In the example below, the scale for the 560/10 is 0-9.000uW/cm?/nm, while
for the 413/10 it is 0-0.100pW/cm?/nm .

To adjust the vertical scale for each channel individually, hover the cursor over an axis and scroll your mouse wheel up
and down. See Vertical zoom for other ways to adjust the scale.

80.000

75.000
70.000 .
65.000 1},

60.000

55.000

50.000

45.000

40.000

Pressure (dbar)

35.000

30.000

radiance 413/10nm (uW/cm?/nm)
°

25.000

Irradiance 560/10nm (uW/cm?/nm)

Irradiance 445 /10nm (|

20.000

15.000

10.000

15:18:30 15:18:40 15:18:50 15:19:00 15:19:10 15:19:20 15:19:30
Time

Regardless of the view (single axis or multiple axes), the channel table in the Analysis tab retains individual colours for
all channels, matching the colour-coding of the traces in the Plot window.

° To change the colour-coding settings for your chart, go to Settings > Plotting > Channel colours.
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7 Irradiance 413/10nm 49941950 pW/cm?*/nm

8 Irradiance 445/10nm 11.2594115  pW/cm?/nm

9 Irradiance 488/10nm 18.3235068 HW/ecm?/nm
10 Irradiance 560/10nm

15.9567764

uW/ecm?/nm
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13.5 Export plot

Click the Export plot button * and select file name
and location to save the current view of the main plot to
a PDF or PNG file. The exported file will contain the graph
only and retain all the changes to display active at the
moment of export: zoom, lines and markers, visible
events and annotations, and plotting by depth or time.

13.6 Appearance controls

i & B-EHrme T
As: | 581_20220613_1311 with markers.pc
Tag
-
were: [ jchapman v - -
L 1 -
f T PDFFile @ B
Ly Eg, [ ".l.'.ll
L iy Enay
.o * 1 + P00 eV VeI y
- = [ X
Ep 3 =
F: 1 o v - L Y i
» : iapdid e -
Ap=" * = i o .¥ * o'..!" .l
ek 3 e e " i . L L 3
ok . = i . . * .
" L]
Mg e "
ghe, & e o
5 13:11:10 13:11:15 13:11:20 13:11:25

Select your data rendering type from the Change line type dropdown menu 2 : Lines, Markers, or Lines and

markers.

NAY @@ @ Q QL e Ty

TNAY @adaaals B

NAY @@ @@ & By

v Lines = Lines F— Lines
Markers Markers
v Lines and markers

Lines and markers

Lines and markers

01:37:15 01:37:16 01:37:17 01:37:18 01:37:

O Y 0L 371 7oL 37 1o 01 37 01:37:15 01:37:16 0137:17 01:37:18 01:37:

° If no data appears in the Plot view, try changing the rendering to Markers. Time spans that are larger than
expected will cause breaks between data points and lines will not be drawn connecting those points, whereas
markers draw at each individual point.
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o w v
Use the Toggle channel visibility button “= to open ¢ v 1: Temperature F—
the dropdown menu with the list of available channels w";w?jmmwwm WETRRA, -
and options. Check and uncheck channels to display as ‘ :: z:a:"“s“’e i
desired, or select groups to show and hide. RETTI  SRTRTETAN i
Show all channels | Show >
Show measured channels z
" Hide >
Show derived channels
Show only > Show raw channels
2: Pressure
4: Sea pressure
5: Depth
09:38 09:40 09:42 09:44 09:46 85:48 09:50 09:52 09:54
Select Show raw channels to display measured data i 203672_2022051 | i 2096812022053 | i AUTO_209681_20 32 =B
with no calibration equations applied. e R A @@d daals B
e v 1: Raw Conductivity
Qs 0.39 1.5006-3 v 2: Raw Temperature E ..
0.024 0.389 1.000E-3 v 3: Raw Pressure
0.388 5
: ZZ: § e g oo : | Show -
E 0.021 20‘3% _é -0.500€-3 Hide >
£ 0020 50'385 S -1.000¢-3 e |
E 0.019 £ oam LBJ -1.500E-3
o.0ms & 038 < -2.000E-3
oor7{ O3 ~2.5006-3
0.016 G -3.0006-3 L
13:10:40 13:10:50 13:11:00 13:11:10 13:11:20
Time

By default, the data are plotted by time. Use the Toggle depth plot .3 button to switch to the plot-by-depth mode.
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The thumbnail view will continue to display the plot-by-time data.

0 If there is no depth channel, the plot will use the next pressure or pressure-derived channel starting from the
bottom of the channel list.

13.7 GPS map

The Show GPS map button o opens a pop-up window with the GPS map for the plot. Click on the map to display all
the GPS location annotations recorded in the dataset.
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[ oW ) 203672_20220517_1240.rsk GPS Locations

GPS mapping for Desktop RSK files relies on manually added location points (see Annotation controls). All location

points you added using the Annotations feature are stored in the dataset file and can be displayed in Ruskin via the
mapping functionality.

0 Charting and continuous GPS tracking are only available on the Ruskin Mobile app, for datasets in the Mobile
storage format.
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14 Plot window

Use the Plot window to view graphical displays of your datasets or live data. When viewing live data, the instrument
must be attached.

Each channel appears as a different colour in the plot. These colours are specified under Settings > Plotting and can be
changed only there.

W 66015 North Atlantic.rsk &2 profiie (7) [V I RA Q@@ AR OB FH-o=0

Move the black "double lollipop" cursor from one sample to the next to display parameter values for each sample
selected. Drag it with your mouse, or use the arrow keys on your keyboard as follows:

¢ To move by one data sample, press right or left arrow
¢ To move by a hundred of samples, press Shift + right arrow or Shift + left arrow
¢ To move by ten thousand of samples, press Alt + right arrow or Alt + left arrow

¢ To move by millions of samples, press Shift + Alt + right arrow or Shift + Alt + left arrow

For the datasets, these values will appear in the Properties window above (see Analysis). For live data, they will be on
the side of the plot.

The graphical display for each dataset or instrument will be in its own tab. The dataset file name or the instrument
model and serial number will appear at the top of the tab. Simulated instruments will have "sim" in front of their name.

# 908870_20260113_1234_realtime.rsk | i 909574_20260113_0908_realtime.rsk | i simRBRduraturo® T 903374 | simRBRduet* D.Tu 905383 2

Atoolbar at the top right of the Plot window contains various buttons to help you customise, explore, and export the
graphical display. The buttons selection changes depending on what is displayed in the tab. Hover over a button to
display its name and function.

| - FrvilAvy @@ Q@ Qg2 ¢ BrfErEEro 0 |[EHSY0e

A downsampled representation of the dataset appears in the thumbnail view, along with an indicator of the current
plotted time range.
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Position the indicator by clicking on the thumbnail view and dragging the indicator. Resize the indicator by dragging the
edges left and right. It will zoom the main plot along the time domain to match the new indicator size. See Zoom
controls for more scaling options.
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A The thumbnail view always shows the plot-by-time data, even if the plot is switched to the plot-by-depth
mode.

When you close and re-open a dataset, it will retain your latest settings (channel visibility, zoom, plot style (plot-by-time
or plot-by-depth), annotation selection, and display style (lines or markers).

Double-click anywhere on the main plot to return to the full-chart view.

° Go to Appearance controls to change your selection of lines and markers.
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15 Live data plot toolbar

You can use the Plot window to view a live graphical display of your instrument sampling. All options described in the

Dataset plot toolbar section apply to live data display. Additionally, three live data buttons appear at the right end of
the toolbar: Side data panel, Live plot time range, and Poll.

Cast
detection _
Appearance Live data
l Zoom controls controls controls
/- oA e @ @R BBl |EEow
Annotation controls T T T
Event Export GPS
visibility plot map

Click the Sample display button “~ to toggle on and off the data panel to the right of the plot. It shows the file
location that will be used to capture samples, the number of samples collected, the values of the last received sample,

and the currently selected sample.

= Gv i A Gy @ \;,' \5{ <;€_;é e . ELNEEE=R

Time:

DR WN - %

12:04:15 12:04:2

Click the Live plot time range ™17 button to opena
dropdown list of time span options.

For example. select 2 minutes to display the data in the
thumbnail view and on the side panel by two-minute
time periods.
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You can also choose to display all of the data collected.

Polling

Live data can come from one of two sources: streaming or polling.

Polling is the action of asking the instrument to take a reading and report it.

Polling can be used on an instrument that is either not enabled or enabled without a streaming option. To disable the
streaming option, go to Options under the Configurations tab and set Realtime to None.

Click the Poll button "™ to start polling data. The button will change to Pause ug . Click the Pause button L to
stop polling.

If streaming is selected (Realtime is set to Serial or USB), clicking the Poll button Ok will have no effect on
the plot.

If the instrument is polling data, but you want to start streaming, go to Options under the Configurations tab and set
Realtime to Serial or USB, then click Enable.

Ruskin will disable polling, close the current dataset used for the polled data, and create a new file for the streamed
U0

data. A new streaming plot will appear. Click the Pause button to freeze the view of live data.

Mw w w Mﬁ w v w o mww«w ]
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16 Firmware updates

Ruskin automatically checks if your instrument firmware is up-to-date. Updates may be critical, routine, or customised.

16.1 Critical firmware updates

If a newer version is available and this update is critical, the Update firmware button and a warning message will
appear at the top of the Deployment tab.

Deployment . Datasets | Calibration
Update

Steps

ece Update instrument firmware

1. Click Update firmware.

! Update instrument firmware

The Update instrument firmware window will © Re-apply firnware version .00
appear. It will contain Release notes, outlining
the new version number, its release date, i Version 1.0.0 - 2 February 2026
improvements, and bug fixes associated with this Reaues s 2250

RBRsolo, RBRduet, RBRcoda® Firmware
release, and two standard buttons at the bottom Il release.

of the window: Close and Proceed.

2. Click Proceed to initialise the update.
The instrument will disappear from the Navigator
window during the upgrade. Watch the progress
bar at the bottom of the window for the status.

0 Do not disconnect the instrument until a confirmation message is displayed. Disconnecting during the update
process may render the instrument inoperable.

If the upgrade does not complete successfully, go to Instruments > Update firmware...
The Update firmware window will appear. Click Proceed again to retry.

If the instrument does not reappear in the Navigator window after a firmware update, disconnect your instrument from
the USB port and then reconnect to establish communication.

16.2 Routine firmware updates

If the latest update is not critical, Ruskin will not display any warning message. However, you can always check
manually if a newer firmware warning is available.
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Go to Instruments > Update instrument firmware.

The Update instrument firmware dialog box will
appear. In addition to the new version number, its
release date, improvements, and bug fixes, there will be
two additional sections: Select the instrument to
update and Select the firmware image.

Steps

1. From the Instrument dropdown, select the
instrument you wish to upgrade.

2. From the firmware selection dropdown, select the
latest firmware image.

3. Click Proceed to initialise the update.
The instrument will disappear from the Navigator
window during the upgrade. Watch the progress
bar at the bottom of the window for the status.

Update instrument firmware

[ N

Update instrument firmware

@ Re-apply firmware version 1.0.0
Select the instrument to upgrade

Instrument  RBRduet* 199991 B

| Select the firmware image

Compact Logger (130) v1.0.0 (2] Import...

Release notes

| Version 1.0.0 - 2 February 2026

Requires Ruskin 2.25.0
RBRsolo*, RBRduet", RBRcoda® Firmware

Initial release.

;

Select the instrument to upgrade

RBRsolo* 240731

A
v

Instrument
Not configured
RBRduraturo* 241215

Instrumen YA [ adrZi oyc| ,

RBRsolo* 239089

Selechth® . e e

Select the

Select the firmware image

v Compact Logger (131) v1.0.0 ) Import...
Compact Logger (131) v1.0.0-rc9
Compact Logger (131) v1.0.0-rc7 ‘
Compact Logger (131) v1.0.0-rc6 ] 2026

0 Do not disconnect the instrument until a confirmation message is displayed.
Disconnecting during the update process may render the instrument inoperable.

If the upgrade does not complete successfully, click Proceed again to retry.
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If the instrument does not reappear in the Navigator window after a firmware update, disconnect your instrument from
the USB port and then reconnect to re-establish communication.

16.3 Manual firmware updates

In certain cases, RBR may supply a customised firmware version, which will not be on the dropdown list.
Go to the Instruments > Update firmware...

The Update logger firmware dialog box will appear. Follow the steps below to import the firmware image provided by
RBR and update your firmware.

Steps

1. In the Update logger firmware dialog box, click Select the firmware image

Import.
port Compact Logger (131) v1.0.0-rc9 Import...

2. Browse to the location of the firmware update file.
The file will have the extension .rbrfw.

3. Select the file and click Open. The file will appear Select the firmware image

on the dropdown list.
P Compact Logger (131) v1.0.0 e Import...

Release notes

Version 1.0.0 - 2 February 2026
Requires Ruskin 2.25.0

RBRsolo*, RBRduet?, RBRcoda* Firmware

Initial release.

4. Click Proceed to initialise the update. The instrument will disappear from the Navigator window during the
upgrade. Watch the progress bar at the bottom of the window for the status.

° Do not disconnect the instrument until a confirmation message is displayed. Disconnecting during the update
process may render the instrument inoperable.
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17 Automatic tasks

When working with a large number of similar instruments, Ruskin offers various automatic tasks.

When using this feature, you will configure your schedule once and then automatically apply the settings to multiple
instruments.

Automatic tasks do not work with wi-fi connected instruments.

H <in File Instruments Help
Access these options from the Instruments menu on the — |
top toolbar. ® © @ Simulate an instrument...
4 T ey .
# Nawgt Update instrument firmware... L = onnection
- “Vins |
ORBF » 2 Auto-download H
®sim s Auto-stop
Oci Utilities >
Osim ) Auto-deploy IF
@®simRBRcoda® 905934 = : : Al
EaMLM View auto-deploy settings...
v £ Datasets I [dev/tty
Alternatively, right-click Instruments in the Navigator + Navigator = =
window. - ;
. . |
ORBRconcerto® Simulate an instrument...
MM v Auto-download
g Datasets
Auto-stop
Auto-deploy

View auto-deploy settings...

When you enable a task, it will show a checkmark next to it, and the corresponding icon will be displayed in the
Navigator window.

Auto-stop  Auto-deploy

v @ Instruments P G‘So'

~
Auto-download

Since these tasks can change the state of your instrument, their settings default to "off" each time Ruskin is run.
When an automatic task is on, Ruskin will execute it as soon as you plug an instrument into your computer.
Auto-download

When Ruskin detects an instrument, it will automatically start a download process. The downloaded dataset will be
named following the standard naming convention, and saved in the default directory. Other than possibly creating
unwanted files, this option is safe since it does not alter the state of the instrument.

Auto-stop

When Ruskin detects a previously enabled instrument, it will automatically stop the deployment. If auto-download is
not selected, it will also display a warning about downloading the instrument data.

Use this feature when Gating is set to Now.
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All the data on the instrument will be erased as soon as you enable a new deployment. RBR recommends
enabling the Auto-download feature whenever you enable Auto-stop.
Auto-deploy

When Ruskin detects an instrument, it will stop the deployment and then reprogram your instrument with the last
known configuration settings. Use this feature when you have several instruments with the same capabilities

All the data on the instrument will be erased as soon as you enable a new deployment. RBR recommends
enabling the Auto-download feature whenever you enable Auto-deploy.
To use this feature, follow these steps:
1. Connect to an instrument that will act as the model.
2. Configure this instrument with the desired settings.

3. Enable Auto-deploy as shown above.

Now, when you connect to an instrument with same capabilities as the model instrument, Ruskin will configure it to
match the the model schedule.

Auto-deploy implies Auto-stop.
Ruskin must stop your instrument to change deployment parameters, so it will stop even when there is no
checkmark next to the Auto-stop task.

View auto-deploy settings

To view the currently active auto-deploy parameters, go to Instruments > Automatic tasks > View auto-deploy
settings... .

The Auto-deploy settings box will open, with saved parameters outlined.

RBR#0020214revA

72



18 Utilities

The Utilities option is a support tool. Contact RBR before using it.

From the Instruments menu, click Utilities. A dropdown LEeEg Hoe =

Simulate an instrument...

menu will open. S
Update instrument firmware... I
Automatic tasks >
Dt
Stop instrument upon detection nodem141101

Connect to networked device...
View connected GPS...

Connect to networked device...

This utility allows a device with serial output to connect to your network via Ethernet. This feature supports remote
management and monitoring of your instruments from anywhere in the world.

. o
1. Select your network device from the dropdown QWO NN Crnet o nseor devie

list. Connect to network device

Please specify IP and port to connect to

v Instrument |

Microsalinometer

NMEA GPS 1
IP Port: 1234
o o Connect to network device

2. Specify the IP address and port.
Connect to network device

Please specify IP and port to connect to

Instrument &
IP Address: 127.0.01
IP Port: 1234

o For the microsalinometer, the port number must be 23.

[ Connections 53

3. Click Connect.

The Connections tab will display instruments and o e v
salinometers connected via Ethernet, alongside T e e o Lot
192.168.5.023:1234 Connected to NMEA GPS 0 GPS

with the instruments physically plugged in to your
computer. Their IP address and port will appear in
the Port column. If an attempt to connect was
unsuccessful, Ruskin will report an error in the
Status column.
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To view connected GPS devices, go to the next utility.

View connected GPS...

This feature allows you to track your instruments during towed deployments. Attach a NMEA GPS to your computer and
connect to it as described above. Alternatively, connect to one of the boat tracking devices if it has an IP address.

Typically, only one GPS is necessary to track your deployment. Using more than one GPS may bring confusion into your
data. Click View connected GPS... to see all listening ports. Click the Port button to disconnect.
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19 Revision history

Revision No. Release Date
A 19 February 2026
RBR#0020214revA

Notes

Initial release
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